Forum Academy Marketplace Showcase Pricing Features

Bubble Page to PDF - New Plugin from Zeroqode

I subscribed to see if this would meet a need for converting single element to PDF. Seems to work well at a high level, and was dead easy to set up, but I’m seeing that it the PDF does not include all of the dynamic elements within the identified element as it should.

The element that is being converted to PDF is this entire content block. Within this block, you can see that the top section is more or less empty. All of the sub-elements themselves are dynamically inserted from data (e.g., background graphic, brand logo, and summary content). The PDF is not picking up any of this. But it is picking up dynamic content elsewhere within the main element, so I’m not sure what’s going on.

Any ideas, @levon?

-Ed (same as @edd but at work)

Okay, I’ve narrowed down the problem a bit. The things that seem not to be showing up are BACKGROUND images, i.e., a group where property Background is set to Image. It makes no difference whether the image chosen is dynamic or static. But if it’s a group with an image background, it does not show up in the exported PDF using your plugin.

Any comments on data protection and privacy? Is data leaving Bubble through an external api to return the pdf?

we are working on some improvements to the plugin currently and will try to solve this as well

no, the data is not leaving anywhere, all the processing is done with code on the client side

1 Like

Looks like your demo page is not working prorperly.
It’s stucked on Please wait…

please bear with us while we are fixing things, I’ll update here once we are done


hey everyone, just wanted to let you know that we have updated the plugin and now it supports:

  1. breaking content into pages
  2. using background images (fixed the bug)
  3. Auto-detecting source page dimensions

Please refresh your editor, install the latest plugin version, refresh the editor again and give it a try.

1 Like

Wow! I am running home right now to try this! Could you just whip up a few screenshots on how it works it would make it so much easier for everyone who views this post.

Just a few simple in fact very simple screenshots that is all that is needed and would really help the beginners out there.

Also running home through the streets of Hong Kong is not an easy task! But that shows you how I am excited about this plug-in!


:slight_smile: Hey Tim,
we have updated the demo page, and now you can see the editor side

hope this helps

1 Like

Ok so I just got home and tried it out! And it is looking pretty awesome!

I’ve not had a chance to dig deep yet but I can’t manage to get it to size right but I’m confident that this is just a configuration error on my part.

I’ve been looking for this solution for so so long! This is going to be the best 7 USD I spend every month!

@levon I can’t thank you enough this is just made my week. And I am now definitely the most happiest man in China!

I just can’t wait to get up tomorrow morning and build some more reports.

Zero code rocks!

Thanks a lot Tim, hope it works really well for you and solves your needs :slight_smile:

Thank you @levonfor being so responsive. It looks like a local fast and easy to use PDF plugin has been in demand for a while. Hope it is very successful for you.

1 Like

Just started using this and it worked brilliantly until it just stopped working. Does this tie up a lot of resources or why would it all the sudden stop making PDFs?

thanks a lot Particia

hmm, very strange behavior, it’s not supposed to do that. And we didn’t push any updates since yesterday.
did you try uninstalling and reinstalling the plugin? It sounds like a Bubble bug and if so would be worth to file a bug report.
Please keep us posted


Just did that and reloaded my browser a couple of times. That seemed to do the trick? Perhaps it wraps up browser resources?

By the way this really is a great plugin!! Very light and fast. Definitely a big benefit to the Bubble community.

Awesome, Brad, thanks for the feedack!

Thanks, @levon. RE: #2 (background images), something still isn’t right. At least one background image (in screenshot below, it’s the big red header image) is now displaying in the export as expected, which is great. However, not only is the smaller image (which should be in the gray circle in the top section) still not displaying in the PDF export, clicking the button that triggers your PDF plug-in actually causes this image to disappear in my app itself. I show the Bubble inspector here so you can see that the Background Image that’s supposed to be in that gray circle is there, but it’s no longer displaying.

Worse, all other like images are disappearing as well (see below: prior to triggering the plugin PDF action, these circles are all filled with images)

Any ideas?

Perhaps worth noting that the red header image is an image uploaded via Bubble, while the ones that aren’t working are external images (in this case from Twitter). For completeness, here are those same two images from above before triggering the PDF export action:


I seem to be having an issue in Chrome where the Print button just does not work anymore after a couple of prints. Is anybody else experiencing this?

I especially see this if I go to the same page with different dynamic content and go to print again. The rest of the workflow works but the print to pdf doesn’t.

Ok got some more info. Error messages are popping up that read

On Chrome- “This plugin Bubble Page to PDF Converter threw the following error: is not a function.”

On IE - “The plugin Bubble Page to PDF converter threw the following error: Object doesn’t support property or method ‘Map’”