Forum Academy Marketplace Showcase Pricing Features

Bubble taking a long time to save

Bubble is either not saving or taking a really long time.

It started happening when I created a “switch” using a custom state “counter” where +1 would toggle the switch. In the conditionals, I am using the modulo operator to figure out if the counter is odd or even. I’m not sure but it seems this calculation could be slowing the app down?

Also, I recently added a handful of iconify logos (these seem to be working well, so don’t suspect an issue here).

Hello,

There are a few things that our team can recommend as means of improving your app editor’s performance:

  1. Do make sure that you only have one editor window open at a time;
  2. Refresh your editor frequently; we recommend at least once an hour, especially for larger and more complex applications.
  3. As a last resort, you can use the &issues_off=true parameter in your URL to turn off the issue checker for the application. Please keep in mind that this turns the checker completely off, which could result in you pushing errors to your Live app; we do recommend removing the parameter to check for issues before deploying.

Please do let us know if you continue to see editor slowness despite these steps!

One big trick I discovered is making sure that your computer’s power management plan is on “performance” for chrome (or whatever browser you’re using). This will drain battery if using an unplugged laptop, but will greatly increase the speed of Bubble in the browser.

You can change this setting using the Nvidia Control Panel or AMD Radeon Settings depending on your graphics card.

For Nvidia, go to “Manage 3d settings”, then “Program Settings”, then select chrome from the dropdown. Scroll down to “Power Management Mode” and select “Prefer Maximum Performance”. Also set “Preferred Graphics Processor for this Program” to your Nvidia graphics if it isn’t already.

Not sure exactly how to do this in AMD Radeon Settings, but I imagine it’s similar.