Bug - workflow behaviour doesn't change, no matter what I do

I have a reset password workflow behaving very strangely. No matter what I do, the workflow’s behaviour doesn’t change. Before you ask, I’m definitely on …/version-test and on Development in the builder.

It’s nothing complicated - just click a button to run the password link workflow. I have even put a condition to only run it when user email = “XYXYXYXYXY” and the workflow still runs it, ignoring the condition.

I have tried disabling the workflow, constraining various workflow actions, etc. The workflow just runs as normal as if nothing was changing. Even deleting the workflow still runs it!

It’s as if my browser was caching the workflow somehow, is this even possible?

Anyone seen something like this before?

Hi! Actually same I met now… Really strange behavior with unpredictable conditions attitude

for me even “Terminate” doesn’t work!

this workflow all fired, any case it met condition or not…

PS. I’m fighting with approach to this simple task already 5 hours using different methods, different plugins, but conditional statement does not work.

Have to note: this is brand new app created just today

Hi one more time!

I found solution for my problem, and I found reason for it happened.

Through all workflow the conditional didn’t get value to compare. Looks like all plugins I used set results states longer, then flow was passing.

To check it you should create some database just for tests reasons and put all the values to compare there near the step you met problem.
For my case I stored states of LocalStorage and got that it is empty (before I just put it dynamic values on index page to see if it filled in - in this term such case fail)

Now I use this trigger to be confirm that states are in place

Hope you will find the answer too!

For you case could you show what are you doing here?

If it’s target to get password reset link, may be you forgot to press this?

Hi Paul. In that step, I’m using “just create token” without sending email.

As you can see, I’m also doing a search over the standard, built-in User data type.

I do a search in the database to check if the email the user entered is there or not, which is what happens in Search for users: count > 0.

I didn’t fully understand what you meant by your solution, did you manage to fix your problem?

1 Like

Seems to have fixed it for me too Paul, thanks for your help!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.