Can't find "Reset Password" in workflows

All the threads about resetting passwords involve using “Reset Password” in the workflow, but I cannot find that action. It doesn’t show up under Account or Element Actions or even a search for Reset. I have Send Password Reset Email, but not Reset Password.

I get all the way to sending the email with the link to the reset password page, but I get an error saying I have to be logged in in order to update the user’s account. I tried using the Magic Link and having it direct me to the password page, but it says the old password doesn’t match. What am I doing wrong? Has Reset Password been moved somewhere else, or is there a setting I have messed up? Everything else is working except this aspect of my app. But this is an extremely important aspect for user-friendly functionality for my app.

You can only do it on the reset_pw page. To get around that if you really want it on a different page, you can get the token, return it from a backend workflow, send the user to the reset_pw page with the token, This URL (as a return URL), and their new password as parameters, and on page load reset the user’s password using the token and password parameters, then redirect them to the return URL so they’re back where they were.

My question isn’t WHERE to reset the password; rather it is HOW? All the articles I have seen on resetting the password use the “Reset Password” action in a workflow, but I cannot find this action anywhere. If I try to use the “Update User’s Credentials” action, it requires you to include the old password, which defeats the whole purpose for updating the password because it was forgotten. Everything is working up until I get to the Reset Password page, but I cannot get it to work from there. What am I doing wrong?

It’s there. The reset password action can be found there.

Yep… it’s right there:

image
It isn’t there in any of my 4 apps. I think I remember it being there about a year ago (the last time I was working with resetting passwords) but it is not there now. I just updated to the latest version of Bubble. Could that have something to do with it not being there now? Like I said, I do a search for it and nothing shows up in any workflow category. Is there a setting I need to fix or something?

(In case someone notices that there is a scrollbar in my screenshot, the only two other options are “Opt-in to Cookies” and “Opt-out from Cookies”.)

Are you on the reset_pw page?

1 Like

OK, I found it on the reset_pw page by scrolling down on one app. (I think I forgot to go the reset_pw page when I checked that one before) but not on the page I am working on. I will do some more investigating. I think I will try reinstalling my app from my last backup and see if that takes care of it. At least I know it is something with the app and not the upgrade or something I am just doing wrong.

Thanks for the help!

Don’t do that… just go to the reset_pw page in your app and it’ll be there… that’s the answer.

Problem solved! I had 2 pages named reset_pw in two different folders. I deleted one (the only one I could and it was the one I was working on) and the other has the Reset Password action. This was the first Bubble app I worked on 2 years ago, and I am finding a lot of things I did wrong back then.

Thanks for your help!

This topic was automatically closed after 70 days. New replies are no longer allowed.