Can't pull data from SearchBox's "typed text"

Hi all,

Hoping someone can help because I’ve been “battling” with this one for a bit - I’ve come up with a workaround, but it’s slow and the performance isn’t good.

I’ve trying to make a sort of Tagging System, using a SearchBox.

https://goals-planning.bubbleapps.io/version-test/temp/sample:custom.plan?debug_mode=true

  1. On the left, you’ll see what I’m “trying” to build
  • User types a goal - if it exists yet, it shows up, otherwise it doesn’t
  • User clicks the + button and it adds that input’s “typed text” to the database as a goal (and shows the list of them just on the right)
  1. THE PROBLEM: It doesn’t work properly
  • type “goal 11”, or “goal 12” (or one that doesn’t exist - one that doesn’t appear in the searchbox list)
  • Click the +
  • It doesn’t appear on the right

I think there’s something wrong with how it’s reading or understanding/pulling the “typed text”

  1. My workaround (which i’d like to get rid of due to slow performance, if the above can be solved)
  • On the right side, it uses an Input Box + a repeating group just below it to display the search results (i also made it so that if i click one in the RG, it gets added on the right)
  • When clicking the +, it takes the Input’s Value and adds it as a goal

SO
Can anyone perhaps help to explain why/how:
A) I’m using it incorrectly
or
B) The SearchBox isn’t working correctly

Thank you!

I think on your search box on the left, you haven’t selected “Allow entries not in list”. You can’t access the typed text if that’s not checked, as it’s cleared as soon as the search box loses focus, if it’s not a valid entry.

1 Like

Thanks for the reply.

Sorry, yes, I forgot to enable that for this page to “demo” my issue - I just enabled that option and it’s still not working…

Usually people set their application to everyone can edit to get support because it is pretty hard to tell the problem without being able to see what you did.

Ok, i haven’t done it before - I think I just enabled that…

I tweaked it so it’s working: https://bubble.io/page?type=page&name=temp&id=goals-planning&tab=tabs-2

Firstly your button click action was getting text from a missing element. Secondly, your condition, where you’re doing a search to see if the goal already exists, is unnecessary- you can just check for “If search box’s value is empty” (value is always empty unless the text matches a data entry)

Ok, I created a temp2 page and you can go look at what I did to make it work. The issue was you were trying to have your search box find items from the “activity_long_term_goal” table that contained the value you were typing. You don’t need that.

Look at what I did and you can see it works.

Marc

@mguerrasio Haha, two strangers solving someone’s issue at the same time :smiley: Sometime’s I think this forum is too helpful :wink:

Ah, perfect!

Such a small annoying thing (spent over an hour trying to get it working!).

Thank you both for the replies :slight_smile:

This topic was automatically closed after 70 days. New replies are no longer allowed.