Forum Academy Marketplace Showcase Pricing Features

Can't upload files to root

Hi bubblers
I am on a paid plan now, I have uploaded files to my app root and it worked fine but now when I upload any file it gives me error page when I try to call it.
So for example if I uploaded “image.jpg” and named the file “image”
When I go to URL https://www.mydomain.com/image
It gives me that this page doesn’t exist.
Weird thing that this just start happening and it worked fine before.
Thanks in advance

Hi,

Uploading files to the hosting root folder or file manager it will look like fileupload/uniqueid/filename or appforest_uf/uniqueid/filename.

May i know are you using external file storage?

Hi and thanks for your reply.
No I am using the upload to the root.
My bubble app - settings- seo/meta tag

Yes, this place also have the url looks like
appforest_uf/uniqueid/filename

Please refer below,

i dont know why it doesnt seem like this in mine.
but now when i tried mydomain.com/version-test/filename it actually worked .
despite the fact that i am on a paid plan!
thanks Mani

Hi @husam.hamdy ,
Exactly you are correct. On paid plan’s, files can be accessed like https://app.bubbleapps.io/version-test/filename it was working.

All the uploaded files to be uploaded to file manager of your bubble app. if the files are wrongly deleted then, those was not will work.
But if your file is present in your file manager but not able to access that file from your root directory please contact bubble support / report your bug to bubble (Bug Report | Bubble).

1 Like

Sir, as Bubble warns, uploaded files are “version specific”. This means you need to first switch to the live version of your app in the editor THEN upload the file to root.

1 Like