Hosting files in the root directory NOT working

Hi, is anyone having issues uploading files to the root directory (under Settings → Seo/metatags) ?

Sometimes it doesn’t upload files at all, other times it uploads them but they are not reachable at

I’m trying to upload manifest.json and sw.js for a PWA, without success…


Hey @snowsnow try refreshing your page on the Bubble editor. Also, clear your cache/history if you’re using Google Chrome to test.

Hi @DjackLowCode , thanks for your reply.

I tried that without success.

A couple of times it did show the link above the upload button, after uploading the file, while in development mode.
But all the other times, both in development mode and in live mode, it uploads the file but nothing shows on top of the upload button.
I can see the file among the uploaded files in the “Data” section, but they are not accessible from the root folder.

1 Like

Files are version-specific, that means that you have to upload them in test and deploy the app from test to live for them to be accesible there.

  • If you are trying to upload the files in the editor in version-live, they won’t be uploaded
  • If you upload a file in the editor in version test, it won’t show up in live until you deploy the app

Also the url should be where filename is whatever you enter in the input in Settings rather than the name of the file itself (file123.js).


hi @jmalmeida
Thanks so much, it worked.

I did read about the root directory files being version-specific, but I did not understand the correct procedure to upload them.
I think your explanation is more accurate and understandable than Bubble manual and builder :slight_smile:

1 Like

Happy to help!

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.