Collapse Group Not Working in 1 App but works in another


I recently have been having issues with things working in one app but not working in another app. I don’t have any background in programming or coding so completely unable to understand why this might be.

For this post this is specifically about a group collapsing or not.

I have the same settings on two different apps and on one app it works and the other it doesn’t, which is the most frustrating thing.

I have attempted to use the debugger but it doesn’t give any kind of information as to why the group would not collapse when it is “hidden / invisible”. The debugger will show accurately when the group is not visible

The strange thing is that if it is visible or not visible the height remains the same ( I checked both apps and this is true on both, the one that works and the one that doesn’t so I assume it is irrelevant )

So at this point, it seems like any kind of information that can be taken from the debugger is not useful for this case. This is also because when I run in step by step or slow or normal modes I see that the element becomes visible and not visible as it is supposed to, but there is no information pertaining to it collapse.

At this point I have no idea what is wrong because the set up is exactly the same.

First app that works:

And the app that doesn’t work:

Both apps function correctly for displaying the group on button press as seen below

  1. Working App

  1. Not working App

Now the real problem is that the group does not collapse when hidden the text below does not move up as it should

  1. Working app ( group is collapsed and text moves up )

  1. Not working App ( group is hidden but does not collapse as text below does not move up )

Any insight as to why something that is set up the same way ( basically just copied from other app ) would work in one app and not the other?

I had an issue with data being saved properly where it worked in one app and when set up exactly the same way in another app it did not work and save the data properly. I reached out to the bubble team about it last week and I believe they are still trying to sort out what is the reason.

Just trying to ping this thread so that somebody might chime in with an idea of the reason it wouldn’t work as it is expected, or the bubble team good take a look at the issue.

Did you try deleting the non-working one (the copy) and rebuilding it from scratch?

Copying in Bubble does not seem to be 100% reliable at the element level. Cloning an entire page or an entire app seems to work more reliably.

Hey there. I know sometimes these things are frustrating. Make sure there is nothing hidden around or behind the object you are trying to hide. Also make sure it’s not overlapping anything too. Check these objects. May need to move things around.


Thank you so much for taking the time to take a look at this and point out what my eyes couldn’t see.

This was the issue, and it is something I need to stay more aware of as I have had problems with the CSS element on the page causing issues with layout before.

Do you have any tips on where is the best place to put the CSS element on the page so that it is still functioning but doesn’t get in the way of any other elements? I’d like to have a “best practice” so that I could always place this element and others like it in a “safe” place.

My concern on this is really magnified when attempting responsive design for mobile and the page size doesn’t give much extra space to place the element.

1 Like

Glad it worked. :slight_smile:

I like to put everything in a pop up. I wonder if the css would work the same way if you put it in a pop up like I do with everything else. May be worth trying. Keeps everything clean.

Good catch! JS and CSS elements work in floating group set to float “beneath the page”, couldn’t get them to work in hidden popup.

However, I don’t think you can move/cut/copy them from where they are into the floating group. Have to create new elements in floating group and fix all your references to the new elements.

Maybe try moving it into a regular group and then change that group into a floating group. That might work.

This topic was automatically closed after 14 days. New replies are no longer allowed.