Forum Academy Marketplace Showcase Pricing Features

Copying and Pasting from Reusable Element to a different page

Hi guys! I’ve already tried searching the Forum for copy and paste of elements between different pages, and I guess there isn’t anything.

My issue is that I’m trying to copy and paste several different elements (text boxes, input boxes, buttons, etc.) after “selecting all” of the elements I’d like to c&p. After copying (I’ve tried both copy with workflows and regular copy), I move to my index page and try pasting these elements into a newly created floating group (I’ve also tried a regular group), and there is just nothing happening it seems.

Another thread @emmanuel said that if it’s within the same browser, it should work. However, it seems like there is absolutely no copying or pasting going on here.

For clarification, the copy method is being performed while viewing the reusable element in edit mode (see screenshot) and then the paste method is being performed while viewing the index page in edit mode.

I use the cmd+c, cmd+v functionality on my Macbook and it works fine for me. Of course, I haven’t done in your app, but not sure why it would matter unless there is something funky with the reusable element stuff.

Yeah, I’ve tried EVERY c&p method.

Can you share the editor link so someone else can try it?

not sure if this is how, but i’ve made it public and here is the URL from my browser’s address bar:

The reusable element is named “Reuse_Group_Search” and the Floating Group is named “FloatingGroup Search”

I think I just did what you were asking for? But not sure. I just used cmd+c, cmd+v. Did I miss something?

I want the internal elements contained within the reusable element copied into the new floating group element located on the index page; therefore, the floating group would contain the internal elements, NOT the reusable element as a whole. I basically need all the elements to be clickable for workflows and if I just add the reusable element itself, then the buttons and input boxes are not clickable as a workflow.

Yeah, I get that, but I didn’t copy the reusable element, I just copied the elements individually. It should do what you want it to, I think?

Edit: Just saw your note in the app. Lemme know how it goes!

ahh so individually? not as a “select all” group?

Yeah, I shift-clicked on the things in there, then did the copy/paste. Seemed to do the trick

yep, seems like c&p doesn’t work after “select all” the elements. You must select the elements individually. Wonder if this was missed on the backend design, @emmanuel?

Thanks @potentialthings for your help! It is appreciated!

1 Like

Hooray!

1 Like

A bug report, if there is a bug, is the best way to do this.

I wasn’t sure if it were a bug or purposefully set that way. Will submit one.