Current Geographic position [Solved] - it was a Chrome bug causing the problem

Bubble is not returning my current geographic position.


Any thoughts?

Your demo’s working fine for me. Perhaps your browser is blocking location requests?

It’s been intermittent. Sometimes this happens on the refresh. I’ve checked with different browsers. I’ll continue checking. Thanks!

Several possibilities, unlikely to be a bug.

Have you added your own Google API key, perhaps it is being rate limited ?

Yeah, I had lofty hopes on that. I’m wondering if it’s a resources issue. This hadn’t been a problem until very recently. I need to do a lot of geo processing on an upcoming app.

I had set up the keys, but it couldn’t hurt to refresh.

Does Bubble use the HTML5 API directly? Might it be a faster solution for finding multiple locations in a single API workflow.
HTML Geolocation API?

Get ready for a very minimalist video. Spoiler alert: the address isn’t calculated. Even without geocoding, after about 30 seconds, the lat/lng has not popped up.
There is nothing else on this page. I’m stumped.

Does anything appear in the console ?

The text element is drawn on the screen, but but it seems to time out. In the console, all the text attributes were noted…

…but now I’m noticing that even the static text within the element doesn’t render as well


So if you right click the desktop you should get something that let’s you see any error messages.

Not bubble but the browser.

Which desktop?

there was not an error noted in the inspector

Now I see an error (and hidden bubble promo).

But there aren’t referrer restrictions:


a clear shot of the restrictions

You get that error when you are using the wrong key. For example using a service account key instead of an API key.

Try recreating a key for Javascript here …

And use that.

As a quick test …

Use this …


…that I created just now, and have tested.

Get ready for the weirdness.
I replaced my key with yours. I tested it and it worked! 1-2 seconds after the page loaded, the lat/lng showed up. It’s slower than before, but I thought we had fixed it. Then I tested it again, and it wouldn’t load. I added a repeating group with a distance to, which is my ultimate goal here, tested it, and neither worked.
At the end of the video, I opened the Chrome dev tools, and this time there wasn’t an error. :crazy_face:

UPDATE: The entire thing was a Chrome Bug

This topic was automatically closed after 14 days. New replies are no longer allowed.