Forum Documentation Showcase Pricing Learn more

Problem with Geographic position (SOLVED)

Hi Bubblers,

I’ve found a problem recently about getting user’s geographic position. I’ve set a condition to show users an instruction to turn location on If the phone’s location is off. It worked fine until recently. If the phone’s location is off, the app won’t load anything at all.

Anyone experienced it?

I did experience something like that, but it was a long time ago, so I’m not completely sure of the details. I’m fairly certain it happened when my Mac’s geo position setting was set to off (so on device level, not browser or page level), so that may explain it in this case too.

I remember finding it strange that I couldn’t use the current geographic position for any condition - not even is empty. From a technical viewpoint I never explored why that is, but it seems when denied location service, it doesn’t even return an empty parameter. I tried formatting as text etc, with no luck. So yeah, I’ve seen this before, and no, you’re not crazy for not getting any results from the conditions :confounded:

I wish this is where I supplied the solution, but unfortunately changes in the app I made at the time removed the need for it, so I never dug deeper. Maybe I at least saved you some time not battling the conditions for a long time, like I did. Sorry I couldn’t be of more help.

1 Like

Thanks for your reply.

It used to work well but it’s not for now. Not sure when it stopped working.

It’s a bug from Bubble system. It’s been resolved.

Thank you Bubble team.

1 Like