Forum Academy Marketplace Showcase Pricing Features

Custom DNS and Domain Settings - Bluehost

I searched high and low for an answer as to how to set up the custom dns and domain settings on Bluehost with no success. Every resource I found was either incomplete, unresolved or related to another web hosting company. After lots of frustration, I was able to find a solution, so I want to pay it forward for anyone who might have this issue moving forward.

For context, you must be on a paid bubble plan or trial for a paid bubble plan in order to use the custom domain so make sure that is activated before you try this.

What I was given by Bubble
Bubble provided me with 4 A records. Two of them had blank names and two of them had the www and each IP address on the blank option matched and IP address on the www option.

What I did with the info
I found a video in Bubble’s domain/dns setup manual telling me to

  1. delete ALL A and CNAME records and
  2. replace them with the records bubble gave me.

The problem is that these were for other web hosting solutions. None for Bluehost. And Bubble had only provided me with A records not CNAME Records.

So I deleted everything like the video said and then tried adding the A records and leaving the C records blank.

I ran into a problem when trying to put all 4 records into the A section in bluehost. The reason is because the blank ones require you to insert the @ symbol signifying they are blank and that returns an error message in bluehost because you are only allowed one blank one!

I had bluehost support help me but I wasn’t confident they had solved the problem because it looked the same way as I did with an error message still coming back and the website wasn’t working even though bubble said everything was working fine on their end. I couldn’t tell if it was the dns settings on just the standard time you have to wait for propagation, but I didn’t want to wait and find out. I had to get rid of that error message!

After reading through the support forums, no one could help me so I made up a solution based on some fragmented pieces of information that I found.

This is what worked for me in Bluehost when setting up my custom Bubble app domain

  1. First I reset all of the settings to the default. (Thank GOD for the reset button!!!)
  2. Second, I started working on the A records. I noticed that there are 3 columns in the A Records.
  • Host Record
  • Points To
  • TTL
    There are 5 rows with unique host record names. You might have to click show all in bottom right to see them all. 4 of those point to the same IP address. The other, which is the local host points to another number that’s shorter than the IP address. I don’t know what it is, but I left it alone. I chose ONE of the bubble IP addresses provided and replaced all 4 of the IP address in the A records with that single IP address. NOTE: I did not change the name of the host record in any of the records, only the IP addresses (e.g. I left all of the existing prefixes of @, www, etc. and I left the TTL at 4 hours which is the minimum). And then I hit save for each record.
  1. I went down to the CNAME records. I noticed that there are the same 3 columns as in the A Records.
  • Host Record
  • Points To
  • TTL
    There are a bunch of rows with unique host record names. Once again, you might have to click show all to see them all. Once again, I didn’t touch the host record field or the TTL field and I replaced all of the points to fields with app.bubble.io.
  1. There are a bunch of more records at the bottom below the CNAME records and also one above the A records. I didn’t touch any of them! The next morning when I woke up, my domain was pointing to my bubble app.
1 Like

Hello Gina,

Thanks for this post.

I tried setting up the domain name - I am with justhost.com, a sub of bluehost.com I think.

One thing I noticed is that until I wait for DNS propagation, I am unable to preview my site, in either modes (Development or Live)?

Did you have this problem too?
Thanks,
Guy (Ottawa, Ontario, Canada).

I am receiving this error message upon checking the DNS.

That’s because you either have a rouge A record in your DNS settings (you can only have the 4 Bubble ones) or like you say you just need to wait for the changes to roll out via propagation.

Looks like your changes are propagating https://www.whatsmydns.net/#A/prolo.biz but you are only using one of Bubble’s IP addresses - you should be using both (so set up all 4 of the A records they are telling you to).

Thanks.
On justhos.com, this is what I have in the A records section:

On justhost.com my DNS servers are set as follows:

Yep, looks right. Just give it time to finish propagating.

All right. Thanks.
Guy

Is it normal that the I cannot preview my Development side too?

Yep - it’s all on the same domain.

1 Like

Are you able to view your site now?

Yes! Thank you for your help!

www.prolo.biz

Under Beta testing with early adopters.