New issue with setting custom domain name?

Hey fam,
I’ve easily set up a dozen custom domains on Bubble previously and have never really had an issue. This time is a bit different. I’ve set the following A records in Namecheap:

According to instructions from the Bubble editor:

It’s been over 24 hours and I still can’t get this custom domain name to connect. Usually it takes just a few minutes. I did notice there are 4 records to connect now instead of the 2 we historically needed. Am I doing something stupidly wrong?

Hey there @zelus_pudding,

It might be a register issue because it doesn’t look like any of your A records are working:

Maybe instead of trying to do A records, create CNAME records with values of

1 Like

Johnny, I always appreciate your help in the forum. Thank you for this!

So, I like that you tried to test my url using Google’s Dig console. I did this too, but I think you entered a different url from the looks of that screenshot. This is what I get back with the correct URL:

So, only seeing 2 records. I assume we’re to see 4? I’m going to give your recommendation of

instead of trying to do A records, create CNAME records with values of

a shot. Will report back.

1 Like

I’m not really sure how to implement your advice :confused: If bubble gives me 4 A records to add to my DNS, which ones do you advise setting as CNAMEs instead?

I’d try doing this:

A CNAME for www value


A CNAME for @ value

Ooops, forgot the n. Hmm… did you click “Check my settings?”

1 Like

Lol, only like a million times :slight_smile:

1 Like

Do you think I should delete one of the pairs of A records? Or are you saying I should be adding these 2 cnames in addition to the 4 A records?

I’d try removing all the A name records you added and replace them with the CNAME

This is how I have it setup, but I’m using Cloudflare

1 Like

Weird. Okay, I’ll try that!

1 Like

So, the suggestion of setting only the CNAME records in Namecheap (in lieu of Bubble’s recommended A records) did not work :frowning: It’s also been over 48 hours since I tried the recommended A record approach and I still can’t connect this domain :frowning:

Any ideas what I’m doing wrong @eve ?

In case it helps, here’s the error message I see when trying to load my app:

Okay, so I’ve figured out the issue. It appears that in my frustration with this custom domain name integration taking longer than usual, I most likely pressed the
Confirm My Settings button too many times. Apparently Cloudlfare places temporary restrictions on domains that have tried to be added to their service too many times within a short period. I imagine this sort of gotcha didn’t exist before Bubble integrated cloudflare by default… but it certainly does now

So moral of the story, have patience and don’t mash the Confirm My Settings button like I did. Honestly, there may have been another issue in place here… but if this issue befalls anyone in the future, please send a polite email to the Bubble team and they’ll fix you up right away. Thanks again @jess for all your help :slight_smile:


I had the same issue :slight_smile:
Thanks for the details.

1 Like

I think I’m right now in the same boat. Just emailed support for help. Thanks @zelus_pudding for documenting the resolution.

This topic was automatically closed after 70 days. New replies are no longer allowed.