Daily.co token not working for me

With the daily.co plugin.
(See video below as well.)

  1. I create a daily private room and save it to the table ‘meetings’ in the column ‘roomUrl’.
  2. Then when I go to join this room, I first create a token, then in the 2nd step is join room, with token from the previous step. The call starts but then just falls away.
  3. I’ve tried saving the token, and it’s being saved. So it is being generated and received.
  4. I’ve tried making the room ‘public’ and joining without the token, and it works perfectly.
  5. I feel like I’ve gone over every setting, and expiry, tried building it up in a new bubble app and I’m still facing the same problem. I’ve scoured this forum to no avail.
  6. It should be an easy problem to solve so I thought I’d put it up here so people in the future having the same problem can use the solution.

I’ve made a short video describing the same thing I outlined above. The first 3 min outlines the problem. Then, in the last minute, I show that if I make the room public it works perfectly. https://youtu.be/07QEGULog9c

Hey @votterskog! In your create meeting token, you’ll want to input the room name not the room URL. In your video you’re putting the room URL in the token, you just need the name. In your database it can be helpful to save both the room URL and the room name.

Here’s an example editor


1 Like

Thank you Lola. That worked in a minute. So easy.

I’ve got a 100 workflows here from a past app where I have referenced the roomUrl for token creation and it has worked just fine. I gave the rows a room name. And in the search for the room, one of the constraints was the roomName, and that made it work in some way. So I thought it was the way. I might go back and change that now that I know that it’s the room name it wants to know just like it says.

Thanks again.

1 Like

Wohooo! Glad it worked out!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.