?debug_mode removed from URL

Hi there

Since yesterday I’m unable to see the Debugger in my app. I noticed that ?debug_mode=true is removed from the URL no matter which page I open, so like:


After page is loaded, URL look like this:


In the browser console I see the following message:

User not logged in and cannot view this app in the editor - cannot see debugger

However, I’m logged into the editor and using the app with the same user. I also see these error messages:


I see the error, but strangely I only see it on my primary browser.

You may try clearing cache, or using another browser. It works as intended for me on Chrome, but not Safari.

If the issue persists, please file a bug report.


Doesn’t work on Safari since many days now, only with Chrome…


Hi @peterj I have reported this as bug #7820 already. This is the reply:


Thanks for reaching out about this. We’re happy to look into this for you. Thank you for creating a test page for our investigation. When we previewed the test page after setting the app’s privacy settings to private, we were able to see the debugger. Please take a look at this
video to see what we observed. Is there any additional context you can give us to reproduce the issue? For example, is this an issue on your end for every page or only for specific pages?

I think because support staff have accounts or system that bypass any application privacy settings they are unable to properly test.

@louis.brauer, if you want to test debug_mode change your application to anyone could view then your debug mode will stay in the url. That’s the only way I know how to make it work rn.

Also im using chrome/brave and experiencing this issue


There may be more than one error here. I’ve tracked down one problem to a change to how Safari handles cross-origin cookies. I’m going to fix that one and see if any Chrome/Brave/Chromium bugs persist.


@eve helped me track down what’s happening here, and it’s a tricky one…

Brave is the “privacy” browser. Safari has an option to prevent cross-site tracking. When you’re in either one of these conditions, the check to see if the user can view the debugging tools fails, because both browsers refuse to send your bubble.io session cookie to bubble to check if you’re logged in and can view the page.

I’m going to have to find a clever workaround here, because browsers are only going to get more strict over time with how much cross site tracking they allow.


Oh i see, i though it was working before with brave but maybe not. Thank you both for helping me try resolve this.

I’m also using Brave. I have set exceptions for the bubble editor + bubble app that disable all sorts of privacy, blocking features; still no luck…

This topic was automatically closed after 14 days. New replies are no longer allowed.