?debug_mode=true not working anymore in non-editor browser?

I use the editor in Firefox but like to preview and debug in chrome to keep FF as clean as possible but as of late whenever I append the debug mode parameters, the page refreshes back to regular version-test. No matter who I use to log in to the app.

Anyone else having this issue?

It works just fine for me. Don’t know what could be wrong. Any chance you had a URL redirect because of, say, SSL or something like that which is changing the URL before it hits Bubble?

No, that has always been the case and it worked fine. Perhaps I need to clear cache although IE and Edge display the same behaviour.

Strange. I’d try a few other things and if you can’t get it then submit it as a bug. Perhaps the Bubble team has seen this before and knows the solution.

Chrome does this to me as well. I have not figured out a trigger yet. Sorta seems to happen when I have developer tools open and reload the page. Sometimes just closing the window and reopening will fix it, sometimes not.

Make sure you’re logged in with bubble in chrome. Only the application editors can use the debugger

Oh yes, totally forgot about that. Couple weeks back something happened that made me have to log back into Bubble. Completely forgot that I was logged into Chrome all this time. Thanks.

Addendum: It also won’t work if you have a tracker blocker turned on (Ghostery in my case), even if you’re logged in to the editor in the same browser.

Hi @vincent56 ,

I am having the same issue than you had… But Emmanuel’s fix doesn’t work for me. Do you have any idea why ?


Google chrome never shows me the debugger. It fixed it for me once I used Firefox and logged in to my Bubble account and then went to preview.

@cdorozco16 Chrome should show debugger, try safe mode by adding parameters ‘&bubble_safe_mode=true&bubble_no_third_party_plugin=true’ after ‘debug_mode=true’

I have the same issue with a new MAC. debug_mode works fine on same project on my other computer.

The parameter debug_mode is actively removed from the URL line once. Smells like a :bug: :mosquito: :beetle:

Safari 13.0.4
macOS Catalina 10.15.2
No popup blocker set

Resolved after logging out of Bubble and then logging back in again.