Forum Academy Marketplace Showcase Pricing Features

Dropdown default value missing

Hi
This is driving me crazy, i read a few posts but my default/opening value is still missing in my dropdown. please see screenshot below:


Page is of Type RECIPE. Halaal is type ‘yes/no’ in RECIPE.

The options in the dropdown is 100%, only the default(opening) value that is missing. The screenshots is from my EDIT page, so the problem is if the user don’t select the option again, it makes a blank selection.

What did i miss please? I want it to display the current value in the database when the page loads.

1 Like

In the debugger or database viewer, what is the value for that field?

Hi
thx for reply. It is ‘yes’, as it should be.

(i hope this capture contain all you are looking for)

The style for the dropdown has a large margin, have you tried first to make the dropdown taller, just to see if it shows anything.

I think your setup is correct @amphi (I just tried to recreate what you did), and am almost sure this is a bug (probably best to file a report). The default value is empty when Type of Choices is yes/no.

Bug Report Form:

I tried a different method where the type of choices was Recipe, Choices source: Search for Recipes, Option caption: Current option’s Halaal, Default value: Current Page’s Recipe. That displays the text correctly, but doesn’t allow you to easily modify the value of the Halaal field since the dropdown’s type of choices isn’t yes/no, using that method.

1 Like

@DaveA, Hi, thank you for the advice, i tried it on your recommendation, still not displaying :frowning:

1 Like

Hi @fayewatson, thank you for taking the time duplicating this, i really appreciate it. I did log a bug request as per suggestion.

2 Likes

While you wait for a fix, a workaround is to use a text dropdown. This means a bit more work for saving the changes later.

1 Like

Hi mate
Thank you for sharing!!
What i actually have have done while i am communicating with @emmanuel via email, is to create a Data Type Yes_No with a ‘yes’ and ‘no’ text value. It basically is a custom made yes/no type, but i have noticed if you make any kind of a dropdown with elements from a data type, it displays them perfectly. This works like a charm!!
@emmanuel also suggested radio buttons, that also did the trick for me, as i use a combination of dropdowns, radio buttons and even check boxes to display this data value, depending on the page and available layout space.
If you want screenshots, lemme know, will gladly send some!!
As per @fayewatson it might be a small bug, once i have a final word i will post it here, but in the interim my ‘custom drop down’ is 100% operational :smile:

2 Likes

I think that is probably a better way anyway, searching the whole database just to get yes/no values seems complex.

1 Like

I seem to to have the same issue. However, my data type is number.

The dropdown has static numbers from 1-99. (I know, not very pretty with a long dropdown like that, but for now it’s ok)

Everything works well writing to the DB but it’s not displaying the [default value] when loading the page. Is it a confirmed bug?

1 Like