Dropdown values not appearing in an edit popup


I am having difficulty populating a dropdown with existing data. Essentially, I’d like users to be able to edit their data in a popup that uses inputs, dropdowns and, in one instance, a multi-dropdown.

So far it’s mostly working; when a user clicks the edit button, the popup appears and all inputs autopopulate with data from the dataset. With the exception of dropdowns and multi-dropdowns. These guys refuse to autopopulate. Dropdowns don’t seem to have an option for “initial content” so I’m not sure where to set this to make it work. Any ideas as to why this is happening?

Hi there, @webshaun… dropdowns don’t have an Initial content field, but they do have a Default value field. Have you tried populating that field with the appropriate expression?


Yeah I’ve tried a bunch of statements but can’t seem to get it to work. Not sure what expression to include. Do you have any thoughts on it?

Of course, and I just figured it out. I made the default value to the option set I used to populate the list and added a filter to it. Thanks for the advice!