Edit mode | multi input | saving from lists / option set | data is erased!

I’m struggling with an issue for which I would really appreciate your help. In short :slight_smile:

  • I create a pop up with custom state (modify then save) to collect information (here about building)

  • This popup uses option set in the dropdown (ex. in this case, year of construction before 1900, between 1900 and 1950, after 1950)

  • When the form is edited, it i supposed to save multiple information about a building (ex. year of construction, classification, …). This information could be modified with the modify / save custom state BUT I realized that information is erased when I fill in information for a new building and when I want to modify an old ones

  • Process works perfectly well when this is not a list

Would you have any explanation for this behavior ?
Many thanks

I didn’t understand what you are trying to say. Maybe someone else can help so my post will bump it to the top.

Second, have you tried using make chages to list?

To create you follow this tutorial here: How to create a list of things on Bubble.io - YouTube

Also you can try autobinding. so you do not need to click save everytime.

Thanks, Ali
Connect with me on Linkedin: https://www.linkedin.com/in/a-imran/
Or book a call to say hi: Calendly - Ali Imran
See my Youtube Tutorials here:

Thanks for your answer. This would be more clear with pictures so I have a form (in a popup) with lists to modify the characteristics of a building.

When I save it, it is registered in the DB but when I want to modify afterwards, some fields already filled in are erased. See below, hopes it clarifies, many thanks 1




Hi there, @igorvetoshev… when you say the fields are erased, do you mean they aren’t showing the values that exist in the database? Also, since you mentioned lists, I assume you are talking about the dropdown fields, and if that is the case, do you have the Default value field for each dropdown element set up to show the current thing’s value for that dropdown?


Well, at first it shows values from the database (ex. age of building : less than 10 years) but when I want to save other fields afterwards (for instance, IGH classification), it erases the value age of the building in the DB. In fact, it reacts as if each time, it had completely new information coming for all fields (except for the ones without dropdown). Otherwise, I don’t have any default value set for each dropdown. Many thanks !

Sorry, but I’m still not getting it. Are you saying when you open the popup to modify an existing building that already has values in the database for the dropdown fields, those fields are being cleared when you click the modify button? If that is the case, when you open the popup, do you see the existing values from the database in the dropdown fields? If you don’t see those values, that is the issue. You have to set up the default value for each dropdown to show the existing data. If you don’t, the dropdown will be considered as empty when the modify button is clicked, and the empty value will overwrite the existing value in the database.

If what I have written above doesn’t make sense, please share a screenshot of the Appearance tab for one of your dropdown elements.

yes, when I open the popup to modify data I can see the existing values but when I edit and save other fields it cleared the fields already filled in.

See below the apparence tab for one of the dropdown
Many thanks,

As I thought, the Default value field in your screenshot is empty. If you move the expression you have in the Placeholder field into the Default value field, your issue should be resolved.

Thanks, how would you design the default value (see below, seems that I need to add something)

Try getting rid of Display at the end of the expression.

1 Like

You are GREAT ! it works perfectly now, many many thanks !

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.