Forum Academy Marketplace Showcase Pricing Features

Editing user profile when it is not contained within "user" data type

I am trying to create/ edit user profiles, but I have my data set up where the profile information is contained within a data type “MakerProfile” rather than “User”. The reason is because I am creating a marketplace where sellers (called makers) can both buy and sell. I am determining if they have a seller posting based on if they create a profile. The issue I am having is that I am struggling to make a place for the current user to edit their own profile (e.g. when I try to create the data, it wants to automatically add user data rather than “MakerProfile” data). Has anyone else run into this problem? I am happy to send screenshots or anything of the data structure if that helps! Thank you for any and all help!

Hi there, @emmakaye… it was a bit hard to follow your description of the issue, but I’m wondering if you have a maker profile field in your User data type that is tied to the MakerProfile data type. If a user is linked to their maker profile through such a field, then you should have access to the MakerProfile fields through the User data type via that field.

So, any of that make sense? If not, then some screenshots that show the issue would probably be helpful.

Best…
Mike

Thank you for getting back to me! I tried to add the “MakerProfile” data type under the user, which did help with connecting the two, but for some reason the information is still not saving to the user. I have attached some screenshots to help explain.

First screenshot shows the profile I am trying to create. I am creating one page for the user to see their profile and then they can edit through a popup.

This screenshot shows the popup where they can edit and save their data.

This screenshot shows the workflow associated, which I assumed would add the data, but it does not seem to be working.

This just shows the data type user. It is sparse because all else is help under “MakerProfile”

Let me know if that helps to clarify! I am sure I am just missing something small.

Hmm, that all looks reasonable. If you populate the data in the maker profile directly in the data type, does it show up on the first screen and in the fields on the popup?

Oh, are you sure you are signed in as a specific user?

So I am signed in, but as a new user. I can’t see the data populating, but I think that is because I linked the data manually in the data so it says that the “created by” is “(App Admin”) so it must not be linked properly. In any case, when I hit the save button, no new data is being created. Let me know if that is confusing and if more screenshots would help at all!

If you’re willing to let me take a look under the hood, I’m sure we can figure it out. If that sounds good, send a private message my way with a link to your editor.

For some reason it says I cannot send you a private message! This is my first time using the forum, so I wonder if that is why.

I just sent you a message to see if you can respond to it. I don’t know how those rules work when you’re new to the community.