Export CSV with emojis in text

Hi All,

Does anyone know if it’s possible to export data from Bubble and keep emojis? I have text fields with emojis and I lose them when I export.


Hey @jamie,

I did a quick test and emoji’s seem to export just fine (using a MAC):

Make sure the app opening the file understands UTF8 files.

Looking to improve your Bubble™ skills?

Let me turn
:thinking: :tired_face: :confounded:

:grinning: :sunglasses: :woman_student:

Coaching and Development at https://uniqueideas.com or schedule a free intro session :gift:

Ken Truesdale

Hi, thank you for your response!

I was opening in Excel 2016 on a Mac. An excel XLS reads them, but I guess not CSV?

Do you happen to know how to view in excel?

Doesn’t work for me either (Excel 2011 on a MAC.) My quick google search leads me to believe that UTF8 files are not supported. Very odd.


Forgot to add this screenshot. It didn’t work for me, but your 2016 version might have better luck. Open an Excel workbook and do an import of a text file rather than double clicking on the csv to open. Try changing using the settings shown here:

ooh ok I will try thanks!!

I went thru the steps a few different ways, but I couldn’t get the data to position correctly in each column. I did figure out another way:

  1. Right click on the CSV export and open with Numbers
  2. Copy all cells
  3. Paste Special as “Unicode Text” into excel

Thanks for your help!

1 Like