Exported CSV file doesn't contain whole data base

Hi everyone!

I’m working with bubble since a few months and things are going well. Now I reached the point to solve some bugs. One of those bugs I’m going to explain below and why I think it’s a data base problem.

According to the use case, the current user is able to sign up. Therefore, he enters username, email address and password in a input field and clicks the sign up button. A new user get created and his data get saved (see workflow below).

image image

Current user gets redirected to another destination and everything works fine, even the user name is shown correctly which means the data got saved.

Issue 1) On the screenshot above you can see the workflow should only run when input’s user name value doesn’t exist already. Even though the entered user name already exists, I can create a new user with the exact same user name. which means the when-function doesn’t work. I tried different kind of solutions but couldn’t solve the issue. And then I found out about

Issue 2) If I go to Data > Data Base > user, I can see the created user but some data like ‘user name’ is missing. Also if I export a CSV file ‘user name’ is missing on the file.

And that’s why I assume the data doesn’t get saved properly. But actually this wouldn’t make sense because the user name is displayed on the users profile for example.

Does anyone have a suggestion what might be the problem?
Many thanks in advance!

Hi Jeannine!

So, second thing first. :slight_smile:

When you are in the Data tab, you can setup different views to display different sets of data. The default views only show limited info, so you just need to modify a new view:

On the Data/App data tab, click the pencil icon next to All Users:

Then click select all for Fields to display, give the view a name and save:

This way you’ll be able to view all your fields.

Now, when signing up a new user, I would probably just add the extra fields you are setting, into the Sign the User Up action, rather than also having a Make changes to user action. In other words, set following, search@username, user name and role, the same way you are setting bio, and then delete the other action.

Test all that out, and (like you are trying to do) look at the data for more clues.

Looking to accelerate your app development?

Let me turn
:thinking: :tired_face: :confounded:

:grinning: :sunglasses: :woman_student:

Development through Coaching at https://uniqueideas.com or schedule a free intro session :gift:

Ken Truesdale

thanks @mebeingken for your answer! the data base thing was very helpful and solved my problem :slight_smile:

To the first issue: the workflow just looks that weird as I tried different things to solve the issue. fortunately I was able to solve it due to the respond from bubble. I gonna share the answer here, in case anyone is struggling with the same:

I’ve been investigating your application and the issue is due to a an unfinished privacy setting set on the User type. If you go to the Data Privacy tab and go to the user type, and delete the unfinished privacy setting, then this issue should resolve.

Regarding the workflows themselves – :count is 0 is a good option versus :count is < 1, because then you can create a second workflow where :count >0 that shows the alert message. This will provide more consistent results, than having a condition on the alert action itself. Let us know if you have additional questions

1 Like