Floating group issues after Bubble change?

We have a floating group in our standard headers that saves us the trouble of adding it manually to every page, but since a few hours all our apps report this issue:


@Bubble did you change something that makes this now impossible?

This sounds to be a new Bubble change (2 posts on that already). You can fix it making all FG in direct (child of page). We are waiting for some Bubble feedback.

@vincent56 We pushed a fix last week where floating groups should not be children of anything other than page.


Oh, i didn’t see any other posts about it. Missed that then, sorry.

I didn’t notice a change log about it. But it seems we would need to make a lot of changes then…

1 Like

OK, got it. Strange that the issues only showed up in the last few hours.

Time to get to work then :smiley:

How do you fix the issue? i.e. how do I make it a child of a page. I have a floating group as reusable header.

You make the reusable element itself a floating group.


Tried converting the reusable element into a floating group. Didn’t work.

Oops! My best guess is that you’re getting this error because you changed an element INSIDE the Reusable element to a floating group.

Try clicking on the base group, the Reusable Element itself. Double check the name, and make sure the screen looks like the screenshot I posted above. You should only get three options as in the picture above. Then set that to Floating Group and you shouldn’t get the issue.

If the problem persists you can try either sharing you editor so we can help you, or you can submit a bug report if you’re certain that the REU itself is misbehaving.

I actually didn’t change anything. The issue just popped up and didn’t know how that could have happened. I tried what you said as per the screenshot below, but it’s still there.

Could I share my editor? I really don’t understand what could be the problem.

@emmanjemuel Sure share away. If it was pre-change, you might need to rebuild it. You can dm me your editor link if you’re more comfortable with that. (sorry for the tardy response, you didn’t @ me and I didn’t see your reply :frowning: )

@duke.severn Sorry. Forgot to do that. Lol. I gave in. Decided to go the long route and stopped using the floating group as a reusable element. Copy-pasted the floating group into each page so it’s now the direct child of the page and manually fixed its workflow on each page. Fixed the issue and the app has been deployed. But thank you for the help.