Fuzzy search not working with extracted from URL

Hi all,

I have tried solutions posted in this thread to no succes - link to thread

The current steps are the same being:

  1. User enters in search from index page
  2. Search is sent as parameter ‘desc’
  3. Input grabs ‘desc’ from url
  4. Fuzzy/autocomplete finds matches from input box

The issue is that no results are shown on page load until the user modifies the value in the input box (same as thread mentioned above). This includes adding a space or deleting a letter, which triggers the repeating group to display results.

I have tried using a custom state to change the input on page load. However, it seems to only work when the user manually changes the input value.

Any suggestions would be hugely appreciated!

Hello, @Joey111 . Thanks for reaching out.

You can avoid using the input search:

Also please note that it is not allowed to use 2 searching variants. You should choose only one - searching by input field or Text to Match field.

Hope it helps. :slightly_smiling_face:

Zeroqode Support Team

Thanks all.

This works at the expense of a delayed live RG update. Nonetheless, it works.

Appreciate the help!

1 Like