Go to Page/Redirect to New slug

Hello, I have it currently setup where I’m using a reusable element, and passing data to it based on the Slug. And it’s working fine.

However, whenever I reset the ‘slug when I’m editing the item’, let’s say in this example based on the name of the item, after clicking submit, the page will break because it can no-longer find the item based on the slug. That’s fine and makes sense…However I tried adding a workflow to ‘Go to Page’ after Set the Thing’s slug, I did this by pulling the Thing’s slug ‘after’ setting the Thing’s slug. And for whatever reason, it won’t pull it properly, it’s either blank or depending on certain order of changes in the model it provides the new ‘slug’ value…but before it gets converted into hypes-numbers,lower cases. So the page will try to redirect to a URL with spaces. Even though I referenced the ‘slug’ and not the ‘name’ of the item.

Is this a bug?

I considered doing some regex to figure out what the slug would be, by replacing spaces with hyphens and making things lower case, but that seems ridiculous and would not work because setting a slug also prevents duplicate slugs by adding a numeration at the end.

See screenshots below for things that I’ve tried.

Any help on this would be great.

This topic was automatically closed after 70 days. New replies are no longer allowed.