Google API for Maps doesn't work

Hi guys,

I’ve been trying to set Google API Keys for Google Maps in order to deploy my app to live. I followed all the instructions in Bubble manual, but it still doesn’t work.

I was told it could be the billing settings in my Google Cloud Platform. So I went back and set the billing information, with all the requested data, credit card, budget alert, etc. Google says the billing is all set and good to go. But still, my map doesn’t work!

Does someone have any clue of what might be happening in my case?

Thank you,

Hello, what happen when you preview your app?
Have you checked the error console during preview with debug mode?

Yes, something appears to have “happened” recently.


I can’t see any error while in step-by-step debuger. It only shows me the workflow, it doesn’t show me the API response.

Is there any place I can see the API responses?

Did someone from Bubble said something about this? I didn’t find it yet.
And this is quite an importante issue…

I have 3 apps using Google Maps API… None of them are working at the moment even though they did before

I’ve solved it!

At the “HTTP referrers (web site)” I was using the “" in a wrong way. The correct way is "”. But when I was using Google Cloud it seemed liked the correct notation was “”.

In your case, Boost, it might be the Time Zone API. In May 2020, Google changed its APIs to split off timezone capabilities (previously part of a bundle of Geocode capabilities) into its own API. This means you will have to add the Time Zone API to the capabilities of your app when registering it with Google.

That’s great Tomas

I don’t see the difference in the two quotations you wrote.

We have the Time Zone API, the problem we’re having is with the Javascript Maps API

Hi Boost,
Sorry, I inteded to write an asterisk, but it didn’t show on screen.

The correct notation is “”. I thought it was “asterisk”.

I changed that notation and it worked.