Google maps API not working on premium plan

I have a problem with location searchboxes on my site.

When someone loads the homepage there is an input (searchbox) where the user can type in their location (zipcode) and it would take that person to a page where they could see if the service is available in their neighborhood.

But since the day I upgrated to a personal plan it didnt work anymore… The location autocomplete function is, I think, the main problem. Because only a valid loaction will take the user to the next page. Now every time you type in a location (a zipecode or place name), you have to wait a very long time and eventually bubble will display a error (there is a temporary bug…).
(I added my own geocoding and places api in the settings. (I also verified my domain).)

Is there a way to solve this problem? I feel pretty let down by bubble, because I did not expect to have all these extra problems when you PAY for a plan.

I hope that there is a solution.

I believe the issue is likely further upstream with your Google setup. Could you expand on “you have to wait a very long time”? (ie. are no search results being displayed. You select a result and then try to move to the new page).

Potential Solution 1:
To isolate the issue, can you try temporarily removing your API keys and see if it goes faster when not using your own API keys?

It sounds like you may not have enabled all of the relevant APIs within Google Maps when you set things up. Here’s a walkthrough video:

Potential Solution 2:
Google Maps Search does return zipcode values (ie. 94041 shows Mountain View, CA 94041 USA). However, keep in mind the Google Maps API doesn’t return places (ex. Madison Square Garden) that’s the Google “Places” API. So, if you type something that isn’t a real value and then try to proceed, that could be causing issues.



I fixed the issue by looking at the google error codes in the console by pressing F12.
After some searches I found my solution.

But thank you for responding!


1 Like

Glad you were able to find a solution. Mind sharing the error codes you ran into in the console and how you solved it. It helps others who may run into the same issue in the future.


I first got the: RefererNotAllowedMapError (

Fixed this error by not only adding my own domain to the google API console, but also the standard bubble domain (=
AND(!) by adding those domains as:**

Solution found here:

Second, I got the: ApiNotActivatedMapError (
To fix this error I had to add the Google Maps JavaScript API to my console.

Solution found here:


Great, thanks for sharing.

It was really painful to see the auto search completely gone and was stuck for quite a long time. Saw a lot of people asking the same question but never found the answer, thank you for the detailed explanation @Thimo it worked out really well for me!