Forum Academy Marketplace Showcase Pricing Features

Error appending value to existing Google Sheet via Blockspring

Hi,

I’m trying to push an email address to an existing Google Sheet but have been running into an error for the past ~18 hours. Any ideas?


Hi, nish

My idea is to use Bubble + Zappier integration (there is an option to push data from Bubble to Google Sheet). It works perfectly.

When you see a message like this, email us at [email protected], there is clearly something we should fix :smile:

Hi Kirill,

Thanks for the idea!

I’ve tried it a few times, and sample zap works properly, but I keep getting the following Zapier error:

400 Error: Blank rows cannot be written; use delete instead.

Any idea what might be causing it?

Hi, emmanuel

Have you resolved this issue?
Seems like I’m having the same one.

No, we’re waiting for blockspring for some updates there.

Hi All,

To follow up on this post, I tried integrating Zapier into my bubble app today and I am getting similar errors to the ones described above. Specifically, I want to create a new google sheet row from data in a workflow, and even though the tests run successfully in Zapier, it never fills my spreadsheet with the actual data, but rather only sample data like “text 1, date 1, etc.”.

I did get Zapier to pick up the information in Bubble at one point, but I then ultimately got a 400 Error: Blank Rows cannot be written, use delete instead error.

It seems like I am doing everything right (i.e. matching the data from bubble to Zapier correctly), Google Sheets account works properly, tests come out successful. But for some reason I feel there is an issue with the data from Bubble being passed to Zapier, where Zapier just can’t “read” what’s coming from Bubble.

Could be an entirely Zapier related issue, if so I apologize, but just want to follow up with you guys to make sure everything is right on your end.

Thanks!

I’m having the same problem. Did you find a fix Jonathan?

Hey Greg, been a very long time since I’ve done this but what I would recommend is using the “Append value to sheet” and “update cell” actions under the plugins choices when you build a workflow. That worked for me. Ideally I would like Zapier to work but I think there’s some technical issues in the bubble and zapper connections since it’s still in Beta. I set it up a while ago so give it a shot and let me know if you have any further questions!