Google Sheets + Offline - one login

Hi @ZeroqodeSupport

I need to read (only) data from a G Sheet. The data is global to the Bubble app, so I do not want to log users in using Google. I just want the app to login to Google and access the sheet. Is that possible?

Thanks, Peter

Hello, @philledille!

Thanks for your questions, Peter!

Plugin Google Sheets + Offline precisely allows reading and writing data to google sheets of any authenticated user. Cause of this based on your inquiry it will be not suitable for your purpose. Plugin Google Sheets + Offline is designed for reading and writing data to google sheets only for authenticated Google account users. Since your request is based on the opposite, this plugin will be not suitable for your purpose.

Please let me suggest another plugin, Google Sheets & Charts (Service). It is similar to Google Sheets+Offline, but its main difference is that it allows users to view/edit google sheets without Google account authorization.

If you choose the plugin Google Sheets & Charts, please make sure that you didn’t provide access to other users to do any edits in the google sheets. Check this setting (“Allow Spreadsheet Access” action ):

And one more thing. We have a plugin Google Embedder - Docs, Sheets, Forms, that allows you to embed any Google document like Docs, Sheets, etc into your app. if you want just to display sheets in the embedded this plugin can be suitable for you.

If you have any other questions please feel free to ask, our team is always ready to help :slightly_smiling_face:

Best regards,
Zeroqode Support Team

Thanks for coming back fast on this!

I bought the Google Sheets & Charts (Service). I’ve set up the Service Account and very carefully removed \n and = from the key. But I do get: “Could not sign request token, check private key”.

I did however not add two user roles. I added one and set it to editor. Is that ok?

Also, in the instruction it says to install the Drive API. Is that necessary?

Best, Peter

Hello, @philledille!

Peter, we have reproduced your case. We have created a New Project at the Google Cloud Platform and then repeated all the steps from our documentation and instruction file. And our app didn’t have such an error. So regarding your questions:

Yes, it is necessary. Please follow the guidelines from the link:

All of the API needs to be Enabled.

Please adhere to the guidelines too, because later during the using your application, access restrictions may arise again:


  • then you create the key. As I understood with this item you hadn’t problems;
  • then you need to configure OAuth consent screen:


And finally about keys. This your step is correct. You remove \n & = and replace them with Enter.

Hope it helps :slightly_smiling_face:
Please be so kind to let me know if our advice were helpful.

Best regards,
Zeroqode Support Team

Thanks for the extra info. However, I’m still struggling.

All APIs enabled:

I created the Service Account with two roles:

I copied the service account email:

I added an external Oauth consent screen. For authorized domains I added both and (since thats the domain where the app is). As test users I added the email the from the Bubble account where the app is.

Now to the key:

I replace all \n with nothing (as per Google’s instruction) and I remove my one = at the end of the key and mark and copy like this:

Would really appreciate any tips on where I turn wrong. :blush:

I re-entered the key pasting it directly from the opening in Chrome to Bubble and the manually removed the \n.

Google says to remove trailing = from the key. In your example app you do not do that. How can that work?

Do I need to “Delegating domain-wide authority to the service account”?

I have sernt you my JSON, key and lss so you can do a simple test so we can isolate this to be a key problem and not a setting Google or something else? I will actually send the whole JSON so you can remove the \n and see if I’m doing that wrong. (I will of course after we get it going disable that account and create a new one.)

Thanks again.

Best, Peter

Hello, @philledille!

We have tested your keys in our app and they are correct, :slightly_smiling_face: I have sent a DM with this information, please check.

Removing = everywhere doesn’t affect the result, you can only remove it only at the end of the key, as you wrote above.

This option is not obligatory to make the plugin work. This function is needed if you’d like to delegate to someone (like a corporate account).

If you have new questions, please feel free to contact us.
Best regards,
Zeroqode Support Team

1 Like

Huge thanks @ZeroqodeSupport for helping me with this and getting it to work!!!