Forum Academy Marketplace Showcase Pricing Features

Help conector api

Hello, I want to leave this username and password dynamic. do you have any possibility?
because this data must come from my user

You will have to pass the username and password in the API call not the API itself. Change it from HTTP Basic Auth to None or Self Handled. Then you’ll add a header or parameter (depending on the documentation of the API) and untick “Private” which will allow you to dynamically set the username and password.
See here:

Hi and thanks for the help,.

I tried this but the api doesn’t support, I need to set it to http oauth

Would this be a limitation of my api?

Can you send a link to the api documentation?

For sure

I’m not an expert in this but HTTP Basic Auth option is just bubble’s nicely formatted form. If you were doing this as a curl request it would look something like what is shown in this stackoverflow question.

You can define all the parameters i.e. the header (-H Authorization: Basic where is the base64 encoding of username:password).

This can be done, you just need to play around and do some google as to properly understand what is required in an http basic auth request

Setting up apis is tough at first. If you don’t get it, I’d love to help coach you thru the process!

Learn more

Tired of struggling with Bubble? Are you ready to step-it-up or speed it along? Need some custom code or a plugin built? Contact me today to learn how to book a 1-on-1 session, get your plugin built, or yet freelance building support!

1 Like

Also, you will need a plugin to do the base64 encoding of the dynamic usernames and passwords

I tried a few options to send authentication on the link and my search led me to a That if my browser displays a popup to authenticate it should be disabled, then it confused my searches a bit.But I’ll try to send an authorization in the header and see

Yes. Each one requires something different from the other and this makes it difficult at first and even for those who already understand

I’ll go back to doing some more tests on postman

I can’t speak 100% to this but my guess is that if the post or get request has the necessary headers, then your browser will not prompt for the authentication.

Yes, postman is where I do the set up for all my api calls before going over to bubble

1 Like

Amazingly I analyzed the postman console and the username and password go together as a parameter. I will try to insert some header

Try like below,
Add header “Authorization” and value will be “Basic base64encode(username:password)”.
Hope it works.

how do we connect? im new to APis and im struggling

What’s your doubt

Hey! Feel free to send me a DM and we can set up a time for a coaching session. APIs are a brain melter at first but you’ll learn quick!