Forum Academy Marketplace Showcase Pricing Features

Help nesting an API GET request!

Hey team! New to Bubble and new to APIs in general - help appreciated!

I am trying to query a specific section of a database I built that is currently connected & working with Bubble API connector plugin. However when I GET from the API, the fields I want are returned as a single row of data, and so are a repeated list in the bubble front end

How can I specify Bubble to request only the fields I am looking to target - in this instance /slot/results/payload/inputs, not just /slot/result/ ?? I have found some stuff on stackoverflow about nested parameters, but I can translate to Bubble (and they are also usually for POST requests)

API Call response (Postman)

API response (JSON => CSV, excel…sorry!)

API Call Setup (Bubble)

API Call Fields (Bubble)

As you can see, the fields are propagating correctly in Bubble, I just want to specify the API result to be payload/inputs. The database it’s querying is a list of transactions (2 so far, hence the count number) for booking call times with people with a smart contract.

Nick

My assumption is to send those as parameters in the API call itself

Everything seem to be parsed correctly by API Connector.
The repeating group need to be set on a list, and the list is the “result” one.
Everything inside doesn’t have a list. So actually, everything work correctly. You need to set the RG to Body and access to information using Current cell’s payload inputs’s slot for example to get this data for the current item in the list.

OK - set that up but now it’s not showing anything in the page preview. Here’s the RG setup:

Actually, in the cell , you are call in the API Again. The text should start with Current cell…
Can you share the setting of the RG

RG Setting

Text Cell Setting

Yes that’s fine. Now if you don’t see anything, it may be because the API Call is not working correctly.
In debug_mode, you can inspect the RG and check the data source.

Don’t hesitate to set your app in public view mode and share editor link if possible.

Strange - do I need to have a scheduled workflow or backend workflow setup to call the API correctly?

The call is working, at least according to the plugin:

I think it’s working now! Had to re-type in the API name.

Fingers crossed - thank you so much for the help!

1 Like