Forum Documentation Showcase Pricing Learn more

How are you supposed to import from CSV? It fails non stop and doesn't import everything

Hi everyone, getting frustrated with this. I have a table called Companies which has fields like Address, Company ID, etc. I have a CSV file with 1600 rows on it which has 4 columns on it, one shows Company_ID, one shows full address, one shows company type, and the other shows a yes or no field.

I’m trying to upload them into Bubble but it hasn’t worked for days. What happens is when I first upload the file and click validate, it starts out fast, going 1, 2, 3, 4 etc but after about 20, it slows down to 1 per second, then by 40 it’s at 1 every 2-3 seconds, and by the time it’s validating row 100 it’s honestly taking 5+ seconds per row. It then gets to maybe 250 and just stops saying “250 elements ready for import.” If I proceed to press upload anyway it gives a popup with some error about something timing out. I’ve tried on my Mac and also my higher end desktop PC and they work exactly the same.

So to get around that, I broke my file into multiple files that are 150 records each. I uploaded the first one, it validated all records and worked fine. I then did the second one, and it did the same thing validating them all and then uploaded and then finally did it with my 3rd file with the 3rd group of 150. So now I should have had 450 records imported, however when I browse the actual data in Bubble, it shows 149 records in total, even though I uploaded 3 separate files that all said successful, it only uploaded 149 for some reason. I’ve refreshed and everything but it only shows 149 files. When doing a test it shows it only imported the FIRST file (missing 1 record with 149 out of 150) and even though it validated the rest and said uploaded successfully, all it did was upload 1 which was a huge waste of time as now I have to delete all the records to try again somehow.

So I’m a bit put off as not only is it not working importing but now I can’t even trust it when I do import smaller amounts. I have a few files like this I have to import and I’ve been working on this for literally a week. I’m on the Professional (Legacy) plan it says, just not sure why it’s so insanely slow importing and always fails. We use Salesforce and import files with 5000-8000 records all the time which it does in literally 20 seconds.

The other thing I wanted to add it always does is things like this:

As you can see there’s 99 buildings as I just deleted 50, and it shows 99 entries, and that it’s displaying 50. Yet when you click the select all check box, now the delete button changes to say “Delete (100)” when previously it was “Delete (50)” which doesn’t even make sense as there’s only 99 records.

If I press “Delete (100)” on it I get this:

image

Just wanted to add that now when I try to upload any file or do anything I get this:

Hi @lmoreau

It’s more of a bug for me. Have you completed a bug report?

You’re on Legacy Professional Plan, so the limit is 1000.

It may also be the major report of the cloud flare (Toronto) lately.

image

I can’t even get to 1000, it can’t even handle 200 before it times out and gives an error or just stops and acts like the file only has 200 rows. I didn’t do a bug report as I didn’t know how or that I could. How do I call Bubble Support or open a ticket?