Forum Academy Marketplace Showcase Pricing Features

How to bypass SSL self-signed certificate error in API connector

Hello everyone,

This is my first post here. First of all congratulations for a great product.

I’m creating a custom API connector to communicate with WHM/cPanel (Web Host Manager) on my web server. The WHM is using self-signed SSL certificate.

When running a test API call with API connector, it shows me the following error message:

{“code”:“DEPTH_ZERO_SELF_SIGNED_CERT”}

Is there a way to bypass SSL certificate errors in the API connector? For example, with Postman these certificate errors are bypassed (just like using any programming language you can ignore these errors).

Thanks a lot

3 Likes

Hi there. I have exactly the same issue.

The API service that I am trying to connect to has a problem with the certificate - I spoke to the owner of the service and they have no plan of fixing it on the legacy system I am connecting to.

The call works perfeclty in Postman - but only if I disable SSL verification.

What I need is to send a request that includes “rejectUnauthorized”: false

for example:

request({
“rejectUnauthorized”: false,
“url”: domain+"/api/orders/originator/"+id,
“method”: “GET”,
“headers”:{
“X-API-VERSION”: 1,
“X-API-KEY”: key
}

In node.js this can be fixed by adding the parameter process.env[‘NODE_TLS_REJECT_UNAUTHORIZED’] = ‘0’;

Has anyone figured out how to discable SSL in API calls sent from bubble? If that is not possible that would be a severe setback, as I would have to switch from bubble.io to node.js in the backend instead, forfaiting the whole purpose with no-code.

Thanks, cheers
/Marek

Hello, I’m having the same problem here.

I have a backend two-way SSL NIFI server up and running with listenHTTP configured to receive calls, and I’m trying to secure it.

I have a self-signed certificate for all of this. I’m the only person sending data back and forth to my server via my bubble app.

I can securely run my API call to my Nifi server in postman by turning “Enable SSL certificate verification” OFF.

I’ve configured the bubble API plugin for this call using Client-Side SSL Certificate and providing both the CERT and the KEY content on the parameters.

The issue is that when i try to initialize the call, i get the “self-signed certificate” error, (same as i get with postman if SSL certificate verification is ON.) Isn’t there a way to configure bubble to avoid verification for API purposes?

That would be helpful so i don’t have to get a cert from a valid Certification Authority.

Thank you!

Has any of you found a solution?