Forum Academy Marketplace Showcase Pricing Features

Icons Not Working Properly?

Hey folks,

Has anyone else noticed strange behavior with their Icons? I’ve noticed at least two icons that just won’t show. One is the Bank / Institution / University icon (“fa-bank” / “fa-institution” / “fa-university”), another is the graduate cap (“fa-mortar-board”). I haven’t tried them all - most of my others (at least a dozen) continue to load fine.

You can reproduce it easily by simply dropping an icon on any page and selecting one of the above. It’ll show fine in the design editor, but when running the app, it’s not visible. Selecting a different icon works fine.

I’ve tested this in Chrome, IE, and Firefox, all with the same result - also on two different machines.

I’m assuming this is a bug since it was previously working fine but wanted to confirm.

Working fine on Safari and Chrome. I assume there’s a problem on your side.


@JohnM - thank you for giving it a shot.

Oddly enough, it looks like it’s something in my app. I tested it from multiple devices, multiple browsers (even mobile), and all came back with the same issue. However, If I do it in another Bubble app, it works fine.

So, now the question is what’s screwed up in my app that’s causing this behavior. I can’t imagine it’s anything I’ve directly done. Dropping an icon and selecting the icon is literally all it takes to recreate the problem, and it looks like I can recreate it on nearly any page in the app.

@Emmanuel - any suggestions here?

Without a link it’s pretty much impossible to help.

Probably some conditions or Hide windows?

@emmanuel - I’ll e-mail support with a direct link to a test page. However, it may be tough without actually seeing it “not work” - since the result is simply no icon.

What I did here was:

  1. Create a new page in the app (“test_page”)

  2. Add 5 icons to the page in a row (flag, bank, automobile, graduation cap, birthday cake). I did this by nothing more than selecting the icon from the palette and dropping it on the page.

  3. Add a text description below each icon.

You can see this here:

When the Preview button is clicked and the page is run:

If I do the same in a different Bubble project, it’ll work perfectly. For some reason, these icons (Bank and Graduation Cap, including other variants of them in the palette) have stopped working specifically in this project. I’m not sure whether there are others, although I’m using about a dozen other icons without issue - so at this point I can only identify these two.

Emmanuel, as I said, I’ll send you a link via support to test. I can’t see, or think of, anything I’ve done that would have caused this strange behavior.