Images streched

Hi everyone, I’m new to Bubble and I have a problem with the images I import directly from my computer. The problem is that the images are stretched and I have no option to change the format or the imgx option. Does anyone have a solution?

If you use the ‘zoom’ on the run-mode-rendering on the image settings, it will keep the image’s aspect ratio and make it not look stretched. Does this help?

I don’t why but i don’t have this option, maybe because i’m working with a static image, i’m not sure.

I think there’s no way around it in the new responsive engine for static images. There’s no imgix, there’s no way to set up logic like ‘zoom/crop/…’ properly.

Using dynamic images feels like overkill in certain cases (why on earth would I want to use a query just to load a static image on a landing page?), so the only ‘real’ solution I found so far, is to make sure that you crop your images in the required format/ratio before uploading.

Hopefully imgix-like functionality or more control over how the images are scaled will be added for static images at some point…