Forum Academy Marketplace Showcase Pricing Features

Input sometimes saved, sometimes doesn't

In my app i have a group with 4-5 input elements (single and multiple line).
The user can save it, and then see it again later (reopens the group with the relevant datatype, and put the saved input as the initial content of the inputs).

BUT, the last input element doesn’t update. I checked the database and sometimes it does save it and sometimes doesn’t.
And even when it does, the input doesn’t update. and it happened with only the last input.
So i tried to delete it and make some changes to the data types and make it single input instead if multi.
Nothing helps.
Even in Live mode.

HELP PLEASE!!!

This sounds like it would be occurring due to the specific setup of your app. We will need some more detailed info (multiple screenshots) or for you to share your app (set the app to “Anyone can View” or “Anyone Can Edit” under settings in the editor and share a link.

One thing to note is that the Database is sometimes delayed to show information that has been saved. I’d recommend refreshing the whole Editor page (not just the “refresh data” text) when checking to see if the data was saved

Hi,
It seems like the database is updated - but there’s delay on showing it in the input initial value.

Here are some screenshots.

  1. I enter a new text inside the 3’d input and save it. Looks Like the variable (“pow-weekn”, the last one) is updated.

2)it seems also like the database is updated:

3)BUT when the user reopen the group to make later changes - the new entry doesn’t show up. And it’s only with the 3’d input element:

** (4)Sometimes after several minutes, if i reopen it - it does show up.

What seems to be the problem?

p.s. - Also the same thing in Live mode, and when changing the app language to english.

What would be helpful here if you want others to help is to provide a link to the situation and open your app so others can test and help. it’s likely an issue with your setting but it’s much easier if we can test.

1 Like

Hi, I tried some changes and i think it’s just a delay in showing the thing. I’ll try some more tuning.
Thanks.

Sometimes this can also occur because of data privacy rules.
For instance if the current user as no permission to access this data field.
You might want to check that!

hi @florent.bocquelet, thanks for your reply!
as for now I have no rules, so I guess it’s something else…:open_mouth:

BTW, i’m using a single page and groups which i hide and show (if someone knows a delay relates to that).