Ionic icons not showing

Hello,

Suddenly all ionic icons are squares… Icons are missing also from editor. Has anyone seen this before? it just happened out of no where.
Attaching screenshot.
Thanks :slight_smile:

Try making the parent group fixed with of the icon or the icon itself… it might help please check.

Thank you @veshoe23 Tried it, didn’t work.

1 Like

Hey @yonimn :slight_smile: Can you share a link to the app editor?

Hi @fayewatson I made a new public app for testing. same problem…

Thanks!! :slight_smile:

1 Like

No prob at all! :slight_smile: Hmm, I’m not sure what this could be; I don’t have any issues viewing the icons in the test app for some reason, or in any of my current apps which have ionic icons. I would test on different browsers just to see if there’s any difference between them, and then submit a bug report if you can:

1 Like

Thank you @fayewatson!
this is so wierd, happens to me on all browsers on different machines even… I’ll fill a bug report.
Thanks for your effort! :slight_smile:

1 Like

I’m having a similar problem with icons. On one page in particular, I have 2 buttons each with a custom state to show a cog that spins when the button is clicked. The icon shows up on one button but not the other (the other is a new button created last night). It’s not my “code” that’s broken because I’ve checked and verified it’s working.

Strange!

1 Like

Is that happening with an ionic icons as well? I had a similar thing happen where material icons weren’t always displaying, but I think someone filed a bug report about that recently!

It’s with the font-awesome icons (e.g., [fa] fa-cog [/fa] ) that we can include within other elements, such as text elements.

Ah, I see. Wonder what that could be!

@yonimn Experiencing this too. The icons started displaying again a while back but now they’re not displaying again.

Edit: So now that I thought about why it started displaying again, I realized that a while back I used a VPN. I just tried it now and the icons are back. It might be a CDN/ISP/IP issue. Anyway, you can check out Psiphon3 VPN or any other free one.

I’ve also experienced this with no answers for a direct a cause. Seems random, but I think it is browser-related. Whether IP or browser version or something else, some users can see it and some can’t on the same app. Hopefully someone can find whatever it is.

1 Like

@romanmg Its happening to me across devices, browsers and machines (Mac and PC). I switched to material icons as I have no more time to spend on troubleshooting this. BTW gaby I love your newsletter, really helpful :slight_smile:

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.