Json API repeating group - images not loading in some browsers

Hi Everyone.

I’m having an issue with the json api connector. The images from the json feed do not display in mobile browser or incognito mode, but work fine in normal google chrome. Any ideas why?

This is the feed I’m using: http://www.globiflow.com/podiofeed.php?c=9579&a=265247&f=3507

App: https://yoose-website.bubbleapps.io/![Capture|690x409](upload://ikSyiMRNb0fny9LCiFrkadqscXr.png)

Im a podio/gf dev. What happen is that you are not logged in Podio and file are not public. If you log in Podio in other browser too, ypu will see them. Also, you can directly call the Podio Api instead of using GF feed.

A workaround is to use GF public image link and store it in a field in Podio and make it available in the feed

1 Like

Ahh nice to see another podio / globiflow dev here. I totally overlooked that. will try the public image url. Thanks!!

1 Like

This is strange. The globiflow public image URL is not displaying, even though the debugger recognizes it as an image. tried playing with the URL syntax with no luck. http://pfuserfiles.globiflow.com/934719834-39985-kianitro2018.jpg![Capture|689x361](upload://mQBSqntdjsuPeMj9pSyonGKWsy2.png)

I think the issue come from the http instead of https … Read this topic on GF forum:


Hi, I am struggling with this issue!
Do you know how can I solve this.
My Web App is loading in HTTPS and the images GlobiFlow provide us from Podio is in HTTP.
How can I resolve this?

Read this in GF forum:

And follow my example.
Use :find and replace to set the correct url

Sir, This link is not opening here.

Are you using the GF public link ? If not, this is what you need to store in the Podio Item.

Or better, create a direct API Connection to the Podio API.

Yes, I’m using PUBLIC URL from PODIO through GlobiFlow.
The URL is public also. But the problem is with HTTP & HTTPS.

Yes. But what you are showing in the screenshot, is a link to the private file, not public one. If you can share your app, I can have a look (view mode is enough)

Link I’m getting from Podio through GlobiFlow is: http://pfuserfiles.globiflow.com/1129601183-33942-screenshot20200217at63113pm.png
If I convert the HTTP into HTTPS. Like this: http://pfuserfiles.globiflow.com/1129601183-33942-screenshot20200217at63113pm.png
It will not work.

Here is the flow in GlobiFlow:

The website I’ve created and using these images.
If you will open this first time. Images will work. But If you refresh. Images will not show. And the reason is that the images link is not in HTTPS.

What should we do!

It’s strange. When I use Podio URL instead of Public URL. It gives us the URL in HTTPS. And it is working now.

IT will work only for you if you are logged in Podio. Sign out from Podio and it will not work.

Did you read my previous post / example and the GF post? You need to replace the first part of the url with the https one in the GF post.

You need to replace http://pfuserfiles.globiflow.com by https://227e3ae233b1be7b91ea-c92c8b85a97b470d1d820c3563880a61.ssl.cf5.rackcdn.com

1 Like

Jici, You saved me brother <3

Thank you very much !!!

I don’t really know how and why this solution is working.
But, this really worked!

1 Like

The issue from http is a security one. HTTPS will avoid to load something from unsecure http.

1 Like

Hi brother, I got an issue when I call Globiflow webhook API.

The issue is (the webhook gives me this, but it is working on the globiflow):
Access to XMLHttpRequest at ‘http://secure.globiflow.com/catch/awud6atsgy’ from origin ‘http://localhost:51850’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

Do you have any idea?