🤯Multiple "ZQ Fuzzy Search and autocomplete" failures on the same page

:exploding_head: We are developing a mobile app using a single page where groups are switched. We have placed the search in several groups (there are 3 in total), where we have put unique identifiers that correspond to the RG in which they should display the result. All other settings are set identical to each other. I will attach screenshots of all the search engines below

The problem is only in one group (example 2), and I can’t understand why. The other search engines work correctly. I won’t attach the example of the third search engine because it also works correctly and differs from the others only by its identifier

  1. It works

  2. It doesn’t work

:exploding_head: Also, there is problem number 2. I have your search standing and also have a pop-up window that serves to filter. But if I start filtering, the search stops working. In the opposite direction is similar. You can see the conditional responsible for sorting in rg in the screenshots from the first example

@ZeroqodeSupport , I would be very grateful for help :yum:

Hello, @nadlennailapp! Thanks for reaching out. :slightly_smiling_face:

Let us please check your request. There might be some delay due to the upcoming weekend, but please be sure we will get back to you once we have any useful updates.

Have a good Friday!
Zeroqode Support Team

Hello, @nadlennailapp
Thanks for your patience.

Due to the fact that we have some additional questions regarding your settings ( the most probably, the issue of your application is in the database settings), can you please add our Support Team email to the list of collaborators to your application and provide us a link to your application?
This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:
Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.

Done! Added

@ZeroqodeSupport Did you get a chance to see it?

Hello, @nadlennailapp

We try to check your application, however we can’t do it together with you. Please put on the pause all your works now :pray:
Thank you!

Best regards,
Zeroqode Support Team

@ZeroqodeSupport, OK, we have stopped making changes

1 Like

Hello, @nadlennailapp

After a detailed analysis of your application, we defined that the Plugin works properly. In the element inspector, we see the correct result.
However, for some reason, the Data Source doesn’t change:

The most probable reason for the occurred issue is the settings of the RG and Data base for exactly this category.
We can propose you create a new page for the Masters section in order to make sure that no extraneous actions are interfering with the plugin.

We understand your feelings and we are sorry for this inconvenience, but we can’t change by ourselves elements in the DataBase or recreate elements of the user’s page in such cases. :pray:

Taking into consideration that the plugin works, but the Repeating Group works incorrectly, allow us to advise you to address your issue to the Bubble Support Team ([email protected]).

Best regards,
Zeroqode Support Team

@ZeroqodeSupport , You have given us an opportunity to think in that direction, thank you! Can you tell me what to do about the filter? How can I make the search work in conjunction with the filter? Right now, if I start filtering rg, the search won’t work anymore. Similarly in the opposite direction

Hello, @nadlennailapp

Please allow us to propose you filter results not by the Data Source of the Repeating Group, but by the result, which appears while you use the plugin.
Unfortunately, we can’t check the filtering option as long as the display of results within your repeating group will not be correct.

Also, allow us to propose you remove the filter’s popup from the application and try to search through the application only with ZQ Fuzzy Search & Autocomplete plugin.

Best regards,
Zeroqode Support Tesm

@ZeroqodeSupport , Do you mean adjust the filtering of the result via workflow? Tell us a little more about how to do this and we will try it
Or do you want to make some changes yourself?

Hello, @nadlennailapp

Please allow me to add more details here.
First of all, due to the fact that you simply sort the information (for example specialists or services) by the alphabet, we propose you remove this popup.

As a solution, if you are willing to sort the information on your website, you can use this feature:

Please note that your filtering popup could affect the plugin’s work. For this reason, we proposed you check the plugin firstly.

Hope this advice will help you.