New Data Fields - Existing Data Entries Not Returned

I have an application that has a data type I created and added some test data to. I later copied that application and all of its database entries to create a new application.

When I first opened the new application and performed a search everything worked as expected (exactly as it had in the original application).

To make the changes to the new application I added some new data fields to my data type. Once I added those new fields and performed a search everything worked as expected and results were returned.

Later I added some constraints to my search to incorporate the newly created data fields. When performing a search no results are returned.

I then tested by adding a data field entry (newly created data field) to one of the existing data type entries. Performed a search and the result was displayed.

To test my theory of a strange disconnect between search results being returned and the newly added data fields, I deleted that new data field entry so as to be blank (my search constraints ignore empty); and my assumption was correct and I still returned that result.

As anybody else every experienced this?

I think it should definitely be addressed as I can only imagine how iterations of a data type would destroy search results by adding a single data field after the application has been in production. If I were to launch live and have a data type of say ‘store listing’ and gathered lots of users who uploaded their store details and I decide at a later date to add a new data field to that data type, all the existing ‘store listings’ would not be returned in search results when constraining for that new data field.

Same here, I created 16 “new database entries” and none of them are seen in my app in any of the repeating groups? I can modify “existing database entries” and see the change but I cannot see “new database entries”

This topic was automatically closed after 14 days. New replies are no longer allowed.