Forum Academy Marketplace Showcase Pricing Features

Not able to Detect Data (in API workflows) to enable webhooks for Razorpay. Will appreciate if anyone can provide an insight here?

Hello,

Step 1: Enabled API workflows.

Step2: Created API workflow

Step 3: Setup webhooks in Razorpay

Step 4: Made a successful pay and created a subscription.

Finally, I have tried waiting till 5 to 7 minutes but I am unable to detect any data.

I have checked data for these events using “requestbin” endpoints, and it works perfectly. Any idea what might be the issue here?

You need to kerp the initialize popup open to let Bubble detect data first. Did you tried this? Once is detected , you need to remove /initialize in url

Hey! thanks for replying…Yes it was open on the page.

What is the event you are trying to capture? Also, try one event at a time?

1 Like

So the initialize stay open waiting for data when you try to trigger the webhook in Razorpay?
Are you on your on domain?

Yes that’s right.

Ya will try single event at a time and update. Thanks.

what is the event you are trying to capture?

payment.captured

Doesn’t seem to work even with a single event! I need to figure something else.

Can you record a screencast of all the process?

Here is the screen recording of all the steps.

Thanks. Your main issue is that you are on free plan and this doesn’t let you expose API endpoint.
Test in a tool like Insomnia or Postman and you will get something like:

{
  "error_class": "Unauthorized",
  "args": {
    "code": "1622382986106x959992887638708700"
  },
  "message": null,
  "translation": "This application does not expose an API. Please upgrade your Bubble subscription for your API calls to run."
}

Ya you are right. I wrote to Bubble support as well and the issue seems to be that API endpoints do not work on Free plans.

thanks for helping me out here! :slight_smile:

1 Like