Forum Academy Marketplace Showcase Pricing Features

OAuth 2 Client Authentication: Send client credentials in body

When I struggle with an API in Bubble I try to simulate the problem in Postman. In this case, I am able to connect to the outside API, authenticate, but when Bubble tries to fetch a token there is a “MISSING_INFO” error. I had the same thing in Postman until I changed my OAuth settings from “Send as Basic Auth Header” to “Send client credentials in body.” The latter worked and I was able to trade an auth code for an access token.

But I don’t see exactly how I replicate that change in the Bubble API connector. I assume sending in the header is default behavior, but I have no idea how to go about changing that to replicate my success in Postman.

Thoughts?

How are you constructing your call that produces the error.

That is the entire error?

The exact error shown in Bubble is
API Connector error: the Oauth2 API DexCom is not configured properly - MISSING_INFO
I was getting the MISSING_INFO error in in the Postman console until I had changed that setting mentioned above.
As for my Bubble config I’ll attach it as an image.

Idk about anyone else, but when I make oauth calls I like to handle the flows myself

I construct the link with the redirect, scope, clientid, and other required info’s in independent calls. Down there

Then you can construct them however you’d like. I know that doesn’t help you here and now sad :pensive: but if you’ve already got the calls going over in postman you can really just copy the settings over quite easily.