PDF Conjurer (updated free plugin, now saving to database)

It’s a problem with metadata on the image, called EXIF. iPhones take pictures flipped like that then just place a metadata on it saying “actually flip it by X so it looks correct”, some photo viewers honor that metadata and show it flipped for you, PDF Conjurer’s engine does not look into metadata.

Find a way to fix that… I once made some code that would route it through browser’s canvas and then reupload it to Bubble to fix it. ChatGPT says you can use some server side code to fix that too.

Here is what it said:

o rotate an image based on its EXIF data on the server side using Node.js, you can use the sharp library, which is a high-performance, easy-to-use image processing library.

Here’s an example of how you can use sharp to auto-rotate an image:

const sharp = require('sharp');

sharp('input.jpg')

.rotate() // auto rotate based on the EXIF Orientation tag

.toFile('output.jpg', function(err) {

// output.jpg is now a rotated version of input.jpg

});

In this code, sharp(‘input.jpg’) creates a sharp instance with the image data from ‘input.jpg’. The .rotate() function then rotates the image based on the EXIF Orientation tag. Finally, .toFile(‘output.jpg’, function(err) {}) writes the image data to ‘output.jpg’.


Good luck! Maybe you can find an API for that. Maybe Bubble’s image operators will fix that.

1 Like

[quote=“paulogustavopeixoto, post:95, topic:43240, full:true”]
what does this error mean? The plugin PDF Conjurer / action Insert image on a PDF Model threw the following error: Cannot read property ‘replace’ of null[/quote]

Hi @vini_brito, I am experiencing a similar error : “Cannot set property 'file of undefined at eval”. Would you know how I could debug this?

Thank you, bro!)
I fixed it with a screenshot. I take a screenshot of the item and save it.

1 Like

Hi,

thank you for this plugin.
I’m facing an issue, it wan’t work, nothing is hapening. I did only 4 steps, see in the capture below :


1/ Init the PDF (PDF Conjurer (backend) | Initialize PDF document)
2/ Init the style (PDF Conjurer (backend) | Define new style to PDF)
3/ Add a simple text (PDF Conjurer (backend) | Add text on PDF)
4/ Generate PDF (PDF Conjurer (backend) | Conjure PDF)

Can you say me what is wrong ?
Many thanks !!!

1 Like

Hello, I don’t know if anyone here is having difficulty with BBCODE… in my situation I am finding that the plugin is not accepting the entire bbCode format:

In the Rich Text:

but when it generates the pdf it doesn’t seem to recognize the bbcode

Can anyone help, I really appreciate it :pray:.

@vini_brito

Hi, maybe someone has encountered this situation. There should be 3 lines of text in the header, but for some reason only one line is displayed.
On the second page of a pdf document, the tabitza overlaps the header. Maybe someone has a solution?)

Hi there,

First of all, hail to the chef @vini_brito , amazing plugin.

I’m having an issue with the PDF conjurer and I’m wondering if it has to do with the amount of text being printed onto the PDF?

So My Workflow starts by creating an A3 size Landscape page orientation, then a title and my logo at the upper left corner. After some styling it proceeds to create two tables, first table with 5 columns second table with 4 columns. And it pulls data from the app which is pure text. (see Image below)

However the amount of text is variable and can range from 50 to words up to 2000k per column.

The problem
The plugin works perfectly 95% but when it faces large amounts of text it generates a partial PDF not completed.

I’m wondering if it has to do with the amount of text?
If anyone can shed some light in the issue I’d appreciate it.

DFD

I decided to go on a text book type of format and it is working.

However, when tried in Safari it gives this error.

The plugin PDF Conjurer / action Create text on a PDF Model threw the following error: RegExp@[native code]
getBreakLineBeforeTag@
prepareContent@ (please report this to the plugin author)

Any ideas?

DFD

HI.Thank you for the great plugin

I’m having trouble because the kanji in column names have become garbled since Ver4.

Ver4
ver4

Ver3
ver3

3.6.0 - Now advanced columns support empty lists. Will be blank column or header only column if no other column has any value.

Im using backend workflow to generate PDFs.

  • When list is not empty : PDF is generated as intended
  • When list is empty I get the following error : TypeError: items_list.length is not a function at eval (eval at build_function (/var/task/util/util_harness.js:38:12), <anonymous>:117:58) at eval (eval at build_function (/var/task/util/util_harness.js:38:12), <anonymous>:154:8) at /var/task/plugin_api_v3.js:275:27 at run_fn (/var/task/u.js:550:18)

Does 3.6.0 change affects backend workflow ?
If not, is there any way to create table with lists that can be empty using backend workflow?

@vini_brito using it for generating reports. But having a problem with the table, Table is not printing values for first column (type text) this is happening with all tables.
Any lead on this?

Hi @vini_brito !

Thanks for this plugin I used to use and loved but… is it still here? I can’t find it anymore on bubble’s plugin marketplace…

Thanks

Hi Teddy! And also anyone interested.
PDF Conjurer got delisted today because I have not updated it to the latest API. I probably will do so eventually, hopefully before January 4 which is when workflow actions stops functioning and breaks apps, but I am taking the opportunity to get users to talk to me, especially people that rely on it commercially.

It is free to use, but it is not free to update them, so I made this page where you can contribute to its maintenance: https://ko-fi.com/viniciusbrito

If not enough contributions happen, unfortunately eventually PDF Conjurer and other plugins of mine will stop working as I cannot work for free forever.

1 Like

Hi, any way that you can fix the PDF Conjurer from crashing when using table BBCodes? We are trying to use PDF Conjurer to load data into an AI so maintaining tables is important. Given the data going in is unstructured HTML I can’t exactly run a process that extracts the table data and then attempt to insert it through the add table function. I need it to accept the bbcode [table] tags.

Even if it doesn’t create a perfect table, I can’t have it bomb and provide no file which is what’s happening now. I literally have to strip ALL table tags before creating the file. Thoughts?

Olá, estive procurando pelo Plugin hoje, mas vi que foi removido da lista, uma dúvida, como vou fazer para começar a usá-lo? estou quase finalizando meu aplicativo, porém só me falta essa geração de PDF, por favor quando puder me dar uma resposta, agradeço muito!

Hi @vini_brito , and thanks for the reply. You totally right. Good luck

1 Like

Hi vini,

Does Conjurer PDF supports Private Image Files?

Why don’t you charge for the new version - monthly usage / one time fee, as everybody else does? 25.000 users !!! If you got $10 (or more…) *20% => 50K budget for this year :smile:

Please, let us know your decision, to cope w/ a budget, or a new plugin in Bubble Market…

Tks in advance Vini

The idea is nice, but there would not be enough sales.
The plugin marketplace is terrible. :roll_eyes:

It is better to keep it like this and try to monetize it indirectly.

1 Like

You did not answer my friend… :slight_smile:

Does Conjurer PDF supports Private Image Files?
When I put a Private Image, it seems to break workflow…
I couldn’t mannage to make it work…

I’d recommend you try charging this app… (don’t bother of what you think it might happen… it is fair to charge for a good product) I’d be one of those who 'd probably buy… There is not a plugin like yours (I’m testing right now!).

Tks in advance,
Augusto

Fair enough! :yum:
Right now I don’t think it supports private images, I have a lead on what would be the problem, which is not following the redirection caused by private files, but I don’t have a solution ready for it.
I would need to spend a few hours at least to add that support.