Forum Academy Marketplace Showcase Pricing Features

Print Pro Plugin by Zeroqode

@levon - was hoping you could help. I just purchased your print pro plugin but I don’t see the “print toolkit” section in my element actions (i only see print by element ID in my plugin actions). Is there a bug ?

Hey, @miguel1!
Thanks for reaching out!
We have already answered via chat, but just in case we will duplicate the respond here for other users :slightly_smiling_face:

Here are all the plugin actions.

If you have placed the element Print Pro Toolkit then you will see its actions. If you’ve placed only the PrintProViewer then you’ll only its actions. So, make sure the page contains the plugin element whose actions are you looking for.

Best,
Zeroqode Team

Thanks! How do i remove the default page title , the date (top left) and the link at the footer when I print?

Also my form has shapes and inputs on it that I want to print but it doesn’t show when I try to print. Can you help there?

Hi, @miguel1!

Whenever you print the whole page there are two options to select: Headers and Footers or Background Graphics. So, unchecked the Headers and Footers option in order to disable the default page title, the date (top left) and the link at the footer.

Could you share screenshots of the plugin elements settings to help you better?

Best,
Zeroqode Team

how about when I only want to print a certain element? How do I get rid of headers and footers?

Hi, @miguel1!

Whenever you print a single element there is no header and footer.

Could you please visit our Live Demo where you can test the plugin and see how it works. Also, you are able to explore its settings and workflow.

Best,
Zeroqode Team

Hi - the inputs and lines still don’t show up when I go to print. Can you help there?

Hi, @miguel1!

To help you better could you please share plugin settings screenshots and element settings screenshots which are you trying to print. Also, please make sure that the inputs are inside the Group you are trying to print.

Looking forward to hearing from you!
Best, Julia.

Please see the screen shots below. Let me know if you need anything else.

Plugin Settings:


Element Settings for ‘lic603aPG1’:



image

Element Settings for ‘lic603aPG2’:



image

an additional screenshot if needed. I have 2 elements (lic603aPG1 and lic603aPG2) inside a group called ‘printGroup’. I’m looking to print each element inside ‘printGroup’ on its own perspective page with the dynamic data and shapes shown.

Hi, @miguel1!

Could you please clarify what browser/OS have you used while testing?

So here are two ways to implement this:

  1. Make more space between the two elements so the browser print in support plugin will share these two elements on the different pages.

  2. Use the plugin action - Print element by ID for the first element in the first step and for the second element in the second step hence.


Hope this helps!
Best,
Zeroqode Team

I’m using chrome. are there browser limitations to the plugin? (need to know as I’ll have users that could be using other browsers)

Hi, @miguel1!

Could up please clarify a bit about what browser limitations are you talking about to help you better? Basically, there are no limitations, the only thing is that preview may be different in different browsers.

Best,
Zeroqode Team

I was referring to the above issue that the plugin is not printing the dynamic data from my inputs along with the shapes (lines) i’ve created on my form. Could you help me understand what I’m doing wrong?

@miguel1,

Sorry for the delayed reply :pray:
Let us please check this first, and then I get back to you with some insights. Thank you!

Regards,
Zeroqode Team

Hi, @miguel1!

We have tested the plugin with the dynamic data and it works well. As for the shapes to make them visible just enable the background on the print preview.

To understand better what is going wrong on your side, could you please add our [email protected] account to your collaborator’s list in Settings -> Collaboration so we could check the issue inside your application. Plus, please tell us the name of your Bubble application and page name where you develop it, it would be way easier for us to help you solve the issues.

Note: avoid the warning message regarding Professional plan, as we are an agency and you can easily add us to your collaborators.

Looking forward to hearing from you!

Best,
Zeroqode Team

Hi @ZeroqodeSupport,

I purchased the plugin yesterday and have found the implementation to be fairly straightforward. Everything works on the desktop. However, when I switch to mobile (in this case iOS), I run into an issue (on both Safari and Chrome) that I can’t remedy. I consistently get the message “This website has been blocked from automatically printing” - when I click on “allow”, I successfully get to the print dialogue, however, the content is empty (in both the preview and when I actually go to print).

Is there a setting that needs to be changed in order for this plugin to work on iOS (I have not yet tried Android)?

I have a deadline of Monday to get this functionality out the door - any help/guidance you can provide would be much appreciated.

Thank you!
Ken

Reference:

Mobile View

Block Message

Blank Preview

Desktop Success

Settings

Hi, there!
Thanks for reaching out!

Let us look through this carefully and we’ll reach back to you asap.

Best,
Zeroqode Team

Hi, @ksaitow1!

So, we have checked this case on different iOS versions and on some of them it worked fine, but on others, we received the same issue. As far as this case is related to the browser settings, but not to the plugin itself, we found a hint that might help you. Please try turning off pop-up blocker in Settings-Safari and give it another try.

Best,
Zeroqode team

Thanks @ZeroqodeSupport for the quick response and your willingness to help me through this. I had checked the pop-up setting prior to logging the support request - Block Pop-ups is set to “off” in the examples I sent.

Any other potential solutions?

Thanks again for the help.

Ken