Repeating group does not display data in preview

Hey guys. I can’t display the data in my repeating group when I click on preview for some reason. I’d greatly appreciate any help provided.

Since you’re pulling info from the URL using a parameter called ‘query’, I looked at the data you have and played around with some of those parameters, and they worked:

@msgiblin Thank you so much for your help. So what should I change the parameters to?

That’s up to you and how you want/need your database and front-end search to work -

You’ll want to make sure something is sending those parameters to the URL. For example, including an Input element on the page, with a button for ‘Search’. On the ‘Search’ button, include a workflow for When this button is clicked: Go to page. Destination: Current page. And then check ‘Send more parameters to the page’. Now click ‘Add another parameter’. Key: ‘query’ = (Input’s value).

Now when you click the Search button, it will update the ‘query’ URL to be whatever value is typed in that Input - and the repeating group will update accordingly. If this is how you want your page & search to work, this will do the trick.

thanks for the detailed explanation! I’ve actually followed these steps to set up the parameter passing via the URL when the search button is clicked, just as you described. However, I’m still running into an issue where the data doesn’t display in the repeating group when I hit preview. I’ve double-checked the workflow and parameters setup. Is there something else I might be missing, or is there another setting that could be affecting the visibility of the data in preview mode? Any further insights would be really appreciated!

Happy to help! We all started somewhere :slight_smile:
Regarding hitting ‘Preview’ and not seeing anything in the repeating group - remember that the repeating group is displaying data based on what it’s seeing in the URL. When you hit ‘Preview’ in the editor, it’s going to open up the URL without any parameters - so the repeating group doesn’t know what to show. Depending on your use-case, this is either a good thing or a bad thing. If you want it to show ALL of the results prior to using the search, simply check the ‘Ignore empty parameters’ on your Do A Search For settings:

image