Forum Documentation Showcase Pricing Learn more

Repeating group height not staying fixed

I am trying to put a repeating group inside a fixed area. I have it looking just fine in the editor, but when previewing, the row height is all off and the content extends beyond the bottom constraint.

I cant figure out what is causing it to be so far off. I don’t see any settings for row height and that white space appears to be the main culprit. Also some of the elements arent lined up properly. The points value looks fine in the first column, but in the second column its smashed up against the name.

Editor:

Preview:

Anyone have suggestions on constraining the height of this RG?

There is a plugin for it from @AliFarahat

Your issue is more a responsive issue than a height issue. You should check your element properties to set the correct behavior if element width is reduced.

My RG is set for fixed width

RG elements are set for fixed width and cut off content

Not sure where else to specify the responsiveness. If the point value on the right column would stop wrapping, it would resolve the issue.

Any idea what its called? At first glance I don’t see one by him that fits my application

Did you try to get the two elements into a group in the cell?

If it doesn’t work, you should send a screenshot from the responsive settings of all elements. So you can get better answers.

1 Like

Once I add a group inside the RG, I dont know how to reference the RGs data.
The text field inside the group now gives the option for Parent Groups Thing. I need parent’s parent’s Ride

image

Please try the following:

Include two elements in a group

Then align this group vertically in the RG - just to make it look better.

Set the group’s “type of content” field to “Ride” (as in the RG).
Data Source is “Current cells ride”.
In this case you will have the chance to use it in the text element.

Extend the width of the “Ride name” text element as much as possible and the length of the element, for example 30 px. (Maybe you can use “fixed widht” or “apply a max widht” in this text element)

The length value you should use in the “Curent Cells … number” element is 30 px according to the example above.

Then align these two elements vertically within the group.

If you still don’t get the result you want, please send images from your elements and responsive settings.

P.S: You’re in a good community :blush:.

There are many videos and forums to learn how to improve your Bubble skills. Yes, responsive settings can take a lot of time, but I think there are more important things to learn before that. Good luck!

2 Likes

Your second text is snapping down, because you’re selecting fixed width on the elements but the RG in your preview is smaller. You don’t need the extra group, though as mentioned it is nice to have for styling sometimes.

From your first screenshot, uncheck fixed width on rg and on the first text element. Min width of first text should be 20. Make sure the right side of first text element is touching left side of second text element 0px margin. Second text can be fixed width. I think it will stay as designed.

2 Likes

Thanks! that ended up working. Still not sure the logic behind it, since fixed width seems to me like it should obey what is designed in the WYSIWYG

@ambarlamedya im going to draft a new version and give your solution a try as well!

2 Likes