Forum Academy Marketplace Showcase Pricing Features

Repeating Group Inside a Repeating Group Continued - Issue Implementing

Continuing the discussion from Repeating group inside repeating group:

Hi @NigelG, I was hoping you could assist me in this matter.

I was trying to follow the instructions you provided in the previous thread (linked above), except instead mine deals with wanting to add Comments on Transactions and not on Locations… All seems to go well until the 2nd step of the workflow. When I go to add the comment from the previous step it will not let me.

Not sure what likely simple step I’m missing…? I’ve been tinkering for hours.

Could it be because I have my Comments repeating group inside of a group that’s then inside of the Transactions repeating group? So technically I suppose there are at least two immediate parents (Comments group, then Transactions repeating group).

Would you happen to recognize what I might be doing wrong? Any guidance would be majorly appreciated!

What is the error message ?

I’m taking a guess here, but it kinda looks like the “Comments” field on the Transaction isn’t of type “Comment.” As Nigel asked, what does the Bubble error message say?

1 Like

Hi @NigelG and @andrewgassen,

Apologies on the late response, work and all!

I’m not sure I know where to look for the error message (?) or if I’m getting one. I just know that the expression in step 2 of the workflow isn’t allowing me to finish the expression (see 1st screenshot), to align with what I thought was directed in the previous thread. Perhaps I’m comparing apples to oranges?

@andrewgassen, I think I have it set up OK.

It is up at the top…

image

Oh duh.

Here are the two I’m getting.

1st error

55%20PM

2nd error

29%20PM

In the second one, you are adding the comment text of the Comment thing to a list of comments.

So just add “result of step 1”.

Hi @NigelG, I tried that a few times.

Still doesn’t seem to work. It keeps wanting me to add onto the expression, and whatever I seem to add it keeps asking for “more”.

24%20AM

That’s why I wasn’t sure if I had too many groups going on that I’m unable to tie things together as a result.

For instance, I have the Comments repeating group inside of a comments Group that’s inside of the Transaction repeating group.

Could my error be because the group that I have my Comments repeating group inside of is set to Type of Content: Transaction… When it should be Type of Content: Comments? But if I changed to “Type of Content: Comments” I wouldn’t be sourcing from the List of Comments in the Transaction any longer, right?

:face_with_raised_eyebrow: Yeesh!

Maybe my approach needs to be a little different than your example…?

You may need to share your app, as am not sure what it is doing :frowning:

1 Like

Hi everyone, just a quick thread update.

Major thanks to @NigelG for helping with this issue. Turns out there was a glitch with the name of the Comment thing. Nigel figured out that when the Comment thing title was changed to something else the title was not changing in the editor. Strange indeed.

Then when the Comment thing table was deleted and rebuilt, it solved the issue. This seemed to be a weird outlier problem. Hard to replicate.

Hopefully this can help someone else so they don’t hit their head against the wall like I was for over a week, ha. Try deleting your thing and rebuilding it and hopefully it’ll work.

Not sure why it broke in the first place, but this is how it was solved. Best of luck!

1 Like

Thanks, yes this was very odd.

The editor refused to recognise the Comment table as a Comment, hence the error that could not be fixed.

Looks like something had got messed in the back end, so changing the name of the table would not be reflected elsewhere.

1 Like