Repeating Group inside of Repeating Group, then "Add a new thing" option when there's no more objects

Hello Bubblers,

Hope you’re Sunday is going well!

I would appreciate someone’s time to help me regarding the Repeating Group inside of the Repeating Group - then adding an option “Add a new…” thing once there are no more objects in the second the repeating groups.

This screenshot shows exactly what I want to achieve

I’ve found an article that shows how to achieve a very similar thing: Bubble Hack: How to create a tile repeating group with an option to add a new item

RG1 Type Role (Data source Search for Roles)
ListOfNumbers A:

RG2 Type number (Data source ListOfNumbers A’s list) - just like in the tutorial.

But I struggle to create a Group inside of RG2, that will pull the info of Goals that belong to that Role. This is what I’ve set so far and it didn’t show anything:

To anyone who has the knowledge and time to help me resolve this, where am I making a mistake and what should I add/remove/change? If more context is needed, let me know and I’ll post.

Best and thank you,

It seems you are struggling referencing the Current cell’s Role from second RG with the Goals. To do that just add an empty group (let’s call it G : Role reference) with type of content “Role” into the Group Goal in the RG with the Goals. See the small red rectangle - this is G : Role reference:

The data source of G : Role reference shall be Parent group Role. If this data source is not available then you might need to package the RG with the Goals into a group container with type of content Role and the data source current cell Role.

After that go to the second RG with the Goals to the data source of the Group Goal and correct it. It should look like this: G : Role reference's Role's Goal-list: item# Current cell's number.

Sergii Shpak
Bubble Developer

1 Like

Thanks a lot Sergii, it worked!

I have packaged the RG2 (with Goals) into a group named Role Reference and it worked. I didn’t know that sometimes you have to group something just to be able to reference it to the object inside. It’s weird that I couldn’t find a reference without it (e.g. current cell Role).

Thanks again!

This topic was automatically closed after 70 days. New replies are no longer allowed.