Forum Academy Marketplace Showcase Pricing Features

Repeating Group not showing API Data

Hi everyone!

Hope you guys can help me here:
I’ve trying to display a user data list that a get from an external API.

I used the bubble tables plugin and it works fine displaying all elements. But now that I’m trying with the Repeating group I cannot get to display any data. Debugger shows every data element fine, just like the plugin table. There’s a difference in the repeting group debugger which is that “is loading” is displaying “no”.

Idk what’s causing it. I tried sending the list from the server differently and reinitializing the call from bubble to setup the datatypes but nothing.
I’ll leave a few pictures.

image



Also tried adding a key to the list but nothing

Hope you guys can guide me through this

“Is loading” means that the repeating group is loading data right now. When it says “no” = the data is loaded to the repeating group.

What you need to check is the data source. On the screenshot, it is visible and also clickable.

Thank for your response, I had to look a tutorial on YouTube since the Bubble docs didn’t mention anything.
I didn’t drag a text element inside the repeating group… That’s why no data was showing :sweat_smile:

If a moderator reads this: I must say the poor documentation is a reason for someone to drop using bubble since it takes more time to learn how to do things. Especially on projects that don’t have a lot of time.