Forum Academy Marketplace Showcase Pricing Features

Responsive header working on the reusable elements, but not when I add to page

Video showing the header in reusable element.

When I am in the reusable element, you can see that the header is responsive in all sizes. When you look to the page, you will see that the 1200 is correct but all other sizes are incorrect. It appears to be pulling to the left.

Any thoughts?

Did you change your page’s layout type from Fixed to Column?

Just from what I saw, that appears to be what the issue is. Maybe. I don’t know. It’d be best to share a link to a view only your app. You can do that by going to Settings > General > Application rights, and click Everyone can view - Just helps diagnosis the issue if we can see some certain settings.

But from just looking at it here, it looks like it could be the container type.

@draked123 timebankbtv | Bubble Editor is the link
Right now it is align to parent. I could try column.

From this screenshot, you can see the issue is your group you have the header inside of, is align to parent. Try changing that to column, you should see the behavior you’re expecting.

@draked123 thanks for checking. I tried changing to “column” on all the other pages. It is not functioning closer, but still not responding like the reusable element header. Do you mind taking a look? Feel free to change it if you can see whats wrong.

If you change it to have permission to edit, I can get the header to respond as expected. Only if you’d like. Just don’t forget to take that away afterwards lol.

1 Like

Changed. Let me know what works, because it did not seem to work with column parent. Also, how will the rest of the page work?

You should be good to go.

A couple of notes:
1.) You don’t need to create a group on the page to contain everything. Think of the page itself as the master group.

2.) Try to use Column and Row container types, as they are the best for responsiveness.

If you ever have a situation similar, just keep an eye on parent groups.

Let me know if you have any other questions and I can try to help!

Thanks so much @draked123

You are awesome! Let me know if I can ever help you with anything!

1 Like

@draked123 was it just the container or did you fix anything? Did you change the re-usable element?

I didn’t touch the reusable. The only issue was the container it was in.

1 Like